Forum: IronRuby Re: Updated IronRuby / Mono install

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jose Antonio D. (Guest)
on 2008-11-07 23:44
(Received via mailing list)
Seo,

Here are the steps that I've taken on my Mac:

  - downloaded and installed the latest Mono binary for Mac
  - revert to rev112 of IronRuby on svn
  - curl
"http://sparcs.kaist.ac.kr/~tinuviel/download/IronR...
" >> patch-mono-r112
  - patch -p0 < patch-mono-r112

that modified the following files:

patching file Rakefile
patching file context.rb
patching file src/microsoft.scripting/hosting/shell/BasicConsole.cs
patching file src/ironruby/Builtins/RubyMethod.cs
patching file src/microsoft.scripting.core/runtime/ReflectionCache.cs
patching file src/microsoft.scripting.core/actions/comdispatch/
comtypelibdesc.cs
patching file src/microsoft.scripting.core/actions/comdispatch/
DispCallable.cs

  - rake compile mono=1


(in /Users/racan/Projects/mono/ironruby)
rake aborted!
No such file or directory - /users/racan/projects/mono/ironruby/src/
microsoft.scripting.core
/Users/racan/Projects/mono/ironruby/Rakefile:159
(See full trace by running task with --trace)



Jose

------------------------------

Message: 6
Date: Fri, 7 Nov 2008 10:39:10 +0900
From: "Seo S." <removed_email_address@domain.invalid>
Subject: Re: [Ironruby-core] Updated IronRuby / Mono install
To: removed_email_address@domain.invalid
Message-ID:
  <removed_email_address@domain.invalid>
Content-Type: text/plain; charset=UTF-8

2008/11/6 Jose Antonio D. <removed_email_address@domain.invalid>:
> Wondering if there is an update to the instructions currently on
> ironruby.net?
>
> I've downloaded the latest stable build of Mono and trying to use
> the latest
> SVN of IronRuby but it doesn't want to compile. Even reverting to
> r112 like
> the instructions said doesn't work.

Really? Reverting back to old versions like r112 does work for me. Can
you detail
what you have done?
Seo S. (Guest)
on 2008-11-08 00:34
(Received via mailing list)
2008/11/8 Jose Antonio D. <removed_email_address@domain.invalid>:
> (in /Users/racan/Projects/mono/ironruby)
> rake aborted!
> No such file or directory -
> /users/racan/projects/mono/ironruby/src/microsoft.scripting.core
> /Users/racan/Projects/mono/ironruby/Rakefile:159
> (See full trace by running task with --trace)

This is weird. Apparently path is downcased (/users/racan/projects vs.
/Users/racan/Projects). What do you get if you run with --trace as the
message says?
Jose Antonio D. (Guest)
on 2008-11-08 01:18
(Received via mailing list)
Trace

(in /Users/racan/Projects/mono/ironruby)
** Invoke compile (first_time)
** Invoke happy (first_time)
** Execute happy
** Invoke clean_build (first_time)
** Invoke happy
** Execute clean_build
** Invoke compile_dlr (first_time)
** Invoke clean_build
** Execute compile_dlr
rake aborted!
No such file or directory - /users/racan/projects/mono/ironruby/src/
microsoft.scripting.core
./context.rb:433:in `chdir'
./context.rb:433:in `compile'
/Users/racan/Projects/mono/ironruby/Rakefile:159
./context.rb:579:in `instance_eval'
./context.rb:579:in `source_context'
/Users/racan/Projects/mono/ironruby/Rakefile:157
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:in `call'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:in `execute'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:508:in
`invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in
`invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:518:in
`invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `send'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:515:in
`invoke_prerequisites'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:507:in
`invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in `synchronize'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in
`invoke_with_call_chain'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:494:in `invoke'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1931:in `invoke_task'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `each'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in
`standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1903:in `top_level'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1881:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in
`standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:1878:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

On Nov 7, 2008, at 3:12 PM, Seo S. wrote:

> message says?
>
> --
> Seo S.
> _______________________________________________
> Ironruby-core mailing list
> removed_email_address@domain.invalid
> http://rubyforge.org/mailman/listinfo/ironruby-core

Jose Antonio D.
removed_email_address@domain.invalid

“For those that understand, no explanation is needed. For those that
do not understand, no explanation is possible.”
This topic is locked and can not be replied to.