Forum: Rails-ES Problema con plugin Prawnto

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Manuel P. (Guest)
on 2008-11-07 22:31
(Received via mailing list)
Hola a todos!
Tengo un problema al momento de instalar el plugin Prawnto, instale la
gema
y el plugin como lo dicen aqui:
http://cracklabs.com/prawnto/use

pero la aplicacion no me corre cuando trato de levantar el mongrel me da
este error:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:263:in
`load_missing_constant': uninitialized constant ActionView::Template
(NameError)
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:453:in
`const_missing'
        from /home/mwp/Proyectos
MWP/sistema_rnc/vendor/plugins/prawnto/init.rb:4:in `evaluate_init_rb'
        from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/rails/plugin.rb:79:in
`evaluate_init_rb'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
        from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/rails/plugin.rb:75:in
`evaluate_init_rb'
        from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/rails/plugin.rb:39:in `load'
        from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/rails/plugin/loader.rb:33:in
`load_plugins'
        from
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/rails/plugin/loader.rb:32:in
`each'
         ... 15 levels...
        from /usr/bin/mongrel_rails:84:in `new'
        from /usr/bin/mongrel_rails:84:in `run'
        from /usr/lib/ruby/1.8/mongrel/command.rb:211:in `run'
        from /usr/bin/mongrel_rails:244

de verdad que no se que hacer, les agradezco si me pueden dar una mano
Manuel P. (Guest)
on 2008-11-07 23:55
(Received via mailing list)
hola de nuevo! ya logre levantar la aplicacion. El error fue corregido

ahora bien, consegui esto por google http://leondu.com/?tag=rails alli
explican como generar un pdf con Prawnto
hice lo que dice alli pero no hace nada.

Alguien ha usado este plugin? si me pueden ayudar por favor muchisimas
gracias


2008/11/8 Manuel P. <removed_email_address@domain.invalid>
Juan M. (Guest)
on 2008-11-14 15:41
> Alguien ha usado este plugin? si me pueden ayudar por favor muchisimas
> gracias

Hola Manuel, te puedo decir que he trabajado con prawnto hace un tiempo
y lo lugares donde aprendí hacer lo que hoy en día uso son en estos
links:
http://cracklabs.com/prawnto/demos
http://prawn.majesticseacreature.com/

me avisas si te sirven. Saludos!!!

-------------------------------------------------------------------
No importa cual es tu meta, lo importante es alcanzarla!
Manuel P. (Guest)
on 2008-11-14 16:15
(Received via mailing list)
gracias juan por responder.... en realidad como lo que necesito imprimir
en
un archivo PDF es muy complicado porque tiene muchas tabla lo que hice
fue
instalar una impresora PDF en las maquinas de windows como cutePDF o
PDFWriter y listo... y bueno las que tienen linux ya sabes que no es
necesario... linux lo tiene todo jejejej :D

El 15 de noviembre de 2008 9:11, Juan M. <
removed_email_address@domain.invalid> escribió:
This topic is locked and can not be replied to.