Forum: JRuby JRuby JDK Requirement?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ray K. (Guest)
on 2008-11-07 17:46
(Received via mailing list)
I've been all over the website, wiki, and faq trying to find the
supported JDK version for JRuby.
I'm assuming that JRuby requires JDK 1.5 or better due to the following
error...

$jruby --help
Exception in thread "main" java.lang.NoClassDefFoundError:
java/lang/Enum
       at
org.jruby.RubyInstanceConfig.<init>(RubyInstanceConfig.java:119)
       at org.jruby.Main.<init>(Main.java:77)
       at org.jruby.Main.main(Main.java:81)

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
Matt B. (Guest)
on 2008-11-07 18:02
(Received via mailing list)
From what I recall, jruby 1.1 moved the minimum java version from 1.4.2
to 1.5/java5.

Ray K. wrote:
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
Bill K. (Guest)
on 2008-11-07 18:03
(Received via mailing list)
On  7 Nov, 2008, at 10:45 AM, Ray K. wrote:

> I've been all over the website, wiki, and faq trying to find the
> supported JDK version for JRuby.

The README file distributed with JRuby mentions this:

== Compiling from source

You will need:

* JDK 1.5 or greater

I know you're not trying to compile it, but if it compiles with 1.5
then it will run with 1.5.

--
Bill K.






---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
David Christiansen (Guest)
on 2008-11-07 18:05
(Received via mailing list)
I've had trouble with 1.5 and have to use 1.6 for my app.

On Fri, Nov 7, 2008 at 11:02 AM, Bill K. <removed_email_address@domain.invalid> 
wrote:

>
>
>
>


--
David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)
Matthew K. (Guest)
on 2008-11-07 18:06
(Received via mailing list)
I've had a few apps in production running on JDK 1.5, and my dev box is
OSX
so only 1.5 ;) so I can say for sure you can run it fine in 1.5.

On Fri, Nov 7, 2008 at 11:04 AM, David Christiansen
Ray K. (Guest)
on 2008-11-07 18:35
(Received via mailing list)
>
> * JDK 1.5 or greater
>
> I know you're not trying to compile it, but if it compiles with 1.5 then it
> will run with 1.5.
>
> --
> Bill K.
>

Aaah yes, the README, didn't look in there. Thanks.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
This topic is locked and can not be replied to.