Forum: Ruby on Rails closed stream occured while loading faster_csv

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Barak I. (Guest)
on 2008-11-05 10:29
Hi,

In my application i am using faster_csv gem to process csv file export
to the client through web request.

Where as in the respective controller i am requiring the gem faster_csv.
But at sme times i am getting the IO:closed stream error. Which says
that this error occures while loading file 'faster_csv'.

I have installed faster_csv gem in my server. I tried running the
mongrel in single server at taht time this error never occuring. But it
is occuring when i tried ruuning the mongrel in multiple ports
(cluster). seriously i couldnt identify what could be the problem.

can anyone guide in this issue to move forwars by solving this issue.

Thanks & Regards,
Barakath
This topic is locked and can not be replied to.