Forum: GNU Radio usrp cant be built error while installing gnuradio 3.1.3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Kaleem A. (Guest)
on 2008-10-31 20:27
(Received via mailing list)
Hi,

I was trying to install gnuradio 3.1.3 but on one computer installation
worked successfully, but on other one it is not building usrp and hence
all
other components which needs usrp.

following is the final result of ./configure command, and follows it are
few
lines from the configuration command where it refuses to build usrp. I
have
also attached the run of complete ./configure command if some one want
to
have a look at it. Please let me know what is the problem and if there
is
some dependancy which I am missing???

*********************************************************************
The following GNU Radio components have been successfully configured:

config
omnithread
gnuradio-core
gr-audio-alsa
gr-audio-oss
gr-atsc
gr-gsm-fr-vocoder
gr-pager
gr-radio-astronomy
gr-trellis
gr-video-sdl
gr-wxgui
gnuradio-examples

You my now run the make command to build these components.

*********************************************************************
The following components were skipped either because you asked not
to build them or they didn't pass configuration checks:

usrp
gr-usrp
gr-audio-jack
gr-audio-osx
gr-audio-portaudio
gr-audio-windows
gr-comedi
gr-gpio
gr-radar-mono
gr-sounder
gr-utils

These components will not be built.


--------------------------------------here are few lines from the run of
the
command-----------------------------------------------------------------------------------------------------------------------
Component usrp requires guile, which was not found.
checking for USB... yes
checking for sdcc... sdcc -mmcs51 --no-xinit-opt
checking for asx8051... asx8051 -plosgff
checking sdcc_version "2.8.0"... 2.8.0
Not building component usrp.
Component gr-usrp requires usrp, which is not being built or specified
via
pre-installed files.
Not building component gr-usrp.
checking for ALSA... yes
Component gr-audio-alsa passed configuration checks; building.
checking for JACK... no
gr-audio-jack requires package jack, not found.
Not building component gr-audio-jack.
checking sys/soundcard.h usability... yes
checking sys/soundcard.h presence... yes
checking for sys/soundcard.h... yes


Best Regards

Kaleem Ahmad

http://www.nabble.com/file/p20271684/Config%2Bresult Config+result
--
View this message in context:
http://www.nabble.com/usrp-cant-be-built-error-whi...
Sent from the GnuRadio mailing list archive at Nabble.com.
Karthik Vijayraghavan (Guest)
on 2008-10-31 22:40
(Received via mailing list)
>
> --------------------------------------here are few lines from the run of
> the
>
> 
command-----------------------------------------------------------------------------------------------------------------------
> Component usrp requires guile, which was not found.
>


You need this dependency, "guile". If you are using Ubuntu then you can
install it from Synaptic.

Regards,
Karthik
This topic is locked and can not be replied to.