Forum: Ruby on Rails Problem starting WEBrick

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
John C. (Guest)
on 2008-10-28 12:14
Ruby nuby here, but this seems like I overlooked something.  I'm running
Rails 2.1.1 on Mac OS Leopard.

I go into terminal and create an app:

  rails whatever

I move into my app and try to start WEBrick

  cd ./whatever
  ruby script/server

And I get the following error:

  Rails requires RubyGems >= . Please install RubyGems and try again:
http://rubygems.rubyforge.org

However, I already have RubyGems 1.3.0 installed, so I'm not sure where
this issue comes from.  The fact that the error also doesn't denote a
RubyGems version seems strange.

Any ideas?  I'm really stuck on this and can't find anything via Google
or the forum.
Craig D. (Guest)
on 2008-10-28 13:24
(Received via mailing list)
Rails checks the RubyGems version using Gem::RubyGemsVersion. I launched
IRB
and queried the version:

$ irb
>> Gem::RubyGemsVersion
=> "1.2.0"

What does yours report?

Based on the error message that you received, I expect it to report an
empty
string.

I'm on Mac OS X 10.5.5 using the built-in Ruby, 1.8.6 p114.

$ ruby -v
ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]

What versions of OS X and Ruby are you running? Did you install Ruby
from
source or via MacPorts or Fink?

Regards,
Craig
John C. (Guest)
on 2008-10-28 18:28
Craig D. wrote:
> Rails checks the RubyGems version using Gem::RubyGemsVersion. I launched
> IRB
> and queried the version:
>
> $ irb
>>> Gem::RubyGemsVersion
> => "1.2.0"
>
> What does yours report?

irb(main):001:0> Gem::RubyGemsVersion
NameError: uninitialized constant Gem
        from (irb):1
irb(main):002:0>


> Based on the error message that you received, I expect it to report an
> empty
> string.
>
> I'm on Mac OS X 10.5.5 using the built-in Ruby, 1.8.6 p114.
>
> $ ruby -v
> ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]
>
> What versions of OS X and Ruby are you running? Did you install Ruby
> from
> source or via MacPorts or Fink?
>

I believe I'm running Ruby 1.8.7 from source.  Again, being a complete
nube, I really have no clue which file(s):

Macintosh-3:~ johnclaus$ ruby --version
ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.4.0]

I'm also running Leopard 10.5.5.

> Regards,
> Craig
Rick (Guest)
on 2008-10-29 05:58
(Received via mailing list)
Since rails comes in as a gem, it's doubtful that you don't have
rubygems installed.  It is possible that you have ruby and gems
installed in non-standard locations.

On my mac:

which ruby => /opt/local/bin/ruby
which gem => /opt/local/bin/gem
which rails => /opt/local/bin/rails

ruby --version => ruby 1.8.7 (2008-08-11 patchlevel 72) [powerpc-
darwin9]
gem --version => 1.3.0
rails --version => Rails 2.2.0

NOTE: This is not what ships on the mac - that's all found below:

/System/Library/Frameworks/Ruby.framework/...

You would probably do best if you go to: http://www.rubyonrails.org/down
and follow the directions there.
This topic is locked and can not be replied to.