Forum: Ruby on Rails generate Model or Migration not getting 001_create.rb

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Wes D. (Guest)
on 2008-10-26 10:55
(Received via mailing list)
When I run "ruby script/generate model users" or "ruby script/generate
migration users" (just as a test to see what number the migrations is
going to give me as a first run on  a newly created project) I get
something like

20081026044945_create_users.rb

when it should be

001_create_users.rb

Man, I have been trying to figure this out all day. I uninstalled
rails and re-installed and tried all kinds of stuff and I cant seem to
get this to work.

I am using Eclipse as my IDE with the APTANA plugin. I have ruby 1.8
installed and rails 2 .x.x installed.

Has anyone else had this problem. I cant seem to find an answer from a
past post.

Thanks!
Fernando P. (Guest)
on 2008-10-26 11:05
There is nothing wrong. This is the new way Rails 2.x creates migration.
It doesn't seem like it, but it is in fact much easier to maintain.

PS: in the future, don't flood the list with the exact same question.
Wes D. (Guest)
on 2008-10-29 18:00
(Received via mailing list)
Yea sorry about that. It took over 2 hours for the first one to come
up. I thought it didn't go through.

On Oct 26, 4:05 am, Fernando P. <removed_email_address@domain.invalid>
This topic is locked and can not be replied to.