Forum: Ruby on Rails UTF-8 compliance in Rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Kiran S. (Guest)
on 2008-10-24 10:34
(Received via mailing list)
I have a issue with UTF-8 compliance... Any solutions?
Frederick C. (Guest)
on 2008-10-24 13:42
(Received via mailing list)
On Oct 24, 7:33 am, kiranH <removed_email_address@domain.invalid> wrote:
> I have a issue with UTF-8 compliance... Any solutions?

You're going to have to give more details than that.

Fred
Kiran S. (Guest)
on 2008-11-04 11:20
(Received via mailing list)
Hi Fred,

  I mean in a given message text posted or submitted in a form,
special characters are inconsistently rendering.

  I need to check whether this is a utf problem or an HTML entity
management problem?

Thanks&Regards,
Kiran.

On Oct 24, 2:41 pm, Frederick C. <removed_email_address@domain.invalid>
Roderick v. (Guest)
on 2008-11-04 12:14
Kiran Soumya wrote:
>   I mean in a given message text posted or submitted in a form,
> special characters are inconsistently rendering.
>
>   I need to check whether this is a utf problem or an HTML entity
> management problem?

Rails works well with UTF-8. When characters are rendering incorrectly
after having been posted, 99% of the time it's an encoding configuration
with the database or an incorrect HTML content type declaration. Have
you checked your database.yml and database encoding setup?

--
Roderick van Domburg
http://www.nedforce.nl
This topic is locked and can not be replied to.