Forum: NGINX Rewrite https://mysite.com to https://www.mysite.com

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Thomas (Guest)
on 2008-10-16 17:04
(Received via mailing list)
Hi list,

I have purchased an SSL certificate for www.mysite.com, therefore I
would like to rewrite any incoming request from https://mysite.com to
https://www.mysite.com in order to avoid the web browser saying the
certificate is not valid and that there my be fraud. How can I do
that?

It works well for http, but for https, the web browser keeps
complaining the certificate is not valide for mysite.com
Phillip B Oldham (Guest)
on 2008-10-16 17:18
(Received via mailing list)
Attachment: phill.vcf (0 Bytes)
Thomas wrote:
>
I'm pretty sure there's no way around this. I believe that the browser,
seeing that you're using the https:// protocol, checks for the
certificate *first* before actually doing a request for the page (which
would return your redirect header).

--

*Phillip B Oldham*
The Activity People
removed_email_address@domain.invalid 
<mailto:removed_email_address@domain.invalid>

------------------------------------------------------------------------

*Policies*

This e-mail and its attachments are intended for the above named
recipient(s) only and may be confidential. If they have come to you in
error, please reply to this e-mail and highlight the error. No action
should be taken regarding content, nor must you copy or show them to
anyone.

This e-mail has been created in the knowledge that Internet e-mail is
not a 100% secure communications medium, and we have taken steps to
ensure that this e-mail and attachments are free from any virus. We must
advise that in keeping with good computing practice the recipient should
ensure they are completely virus free, and that you understand and
observe the lack of security when e-mailing us.
Dave C. (Guest)
on 2008-10-16 17:23
(Received via mailing list)
Hi,

The only option I know of is to purchase an additional certificate for
mysite.com (a wildcard certificate *.mysite.com will not work) and
configure that on a separate IP address which will then handle the
redirect.

Cheers

Dave
Thomas (Guest)
on 2008-10-16 17:40
(Received via mailing list)
You are right there is no way around it except to purchase another
certificate. Even Google didn't bother in purchasing such certificate,
simply go to gmail's login page and change the address by removing the
www, you will see the error message.

Thank you all for your help.
This topic is locked and can not be replied to.