Forum: Radiant CMS tip: page_attachments extension needs submodule initialized

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jason G. (Guest)
on 2008-10-10 20:14
Just a quick tip (and maybe bug report? not sure)...

I tried a simple ./script/extension install page_attachments in my
Radiant 0.6.9 instance and got

rake aborted!
undefined method `has_attachment' for PageAttachment(Table doesn't
exist):Class

The problem was attachment_fu was missing.  It's included via git
submodule, but isn't pulled along with the clone.  So, you have to cd to
the page_attachments extension and

git submodule init
git submodule update

Then cd back up to the app root and rake db:mgrate:extensions and rake
radiant:extensions:update_all.

That should take care of it.  Maybe this workaround means I'm doing
something wrong, but I at least wanted to put it out there for people
googling that error message.

Sean, thanks for maintaining the page_attachments extension!  I tried
out paperclipped, but it's too much for my users.  They _get_ the
simplicity of page_attachments.

Jason G.
Sean C. (Guest)
on 2008-10-10 21:58
(Received via mailing list)
> Sean, thanks for maintaining the page_attachments extension!  I tried
> out paperclipped, but it's too much for my users.  They _get_ the
> simplicity of page_attachments.
>
>
I've handed out maintenance to a couple active developers on it as
well.  I'm sorry about the script/extension install issue.  It's
supposed to initialize git submodules automatically.

Sean
Sean C. (Guest)
on 2008-10-10 22:12
(Received via mailing list)
This topic is locked and can not be replied to.