Forum: Rails Germany Ich verstehe es nicht..

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Werner L. (Guest)
on 2008-10-09 12:16
(Received via mailing list)
Kann mir jemand eine Idee geben..

Normale CRUD anwendung

PLötzlich geht das Editieren nicht mehr. Sagt zwar :gespeichert, aber
ist nichts geändert.

Wenn ich allerdings einen neuen Datensatz anlege klappt alles..nur mit
den bisherigen geht es nicht mehr.

Das läuft doch alles durchs gleiche Schema das kann doch nicht anders
behandelt werden.

Völlig ratlos



Werner L.
Lindenburger Allee 22  -  50931
Köln
0221.8805 635

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

http://www.webagentur-laude.de

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Michael K. (Guest)
on 2008-10-09 12:21
(Received via mailing list)
Hallo Werner,

ist jetzt nicht gerade eine Masse von Infos. Was sagt denn die
Log-Datei?
Vielleicht eine Validation, die keine Message liefert, aber das
Abspeichern
verhindert ...

Viele
Grüße
Michael K.

Werner L. schrieb:
Thomas R. Koll (Guest)
on 2008-10-09 12:24
(Received via mailing list)
Hi,

Da ist's für mich immer Zeit mal save! statt save zu machen.
Oder vllt hast du ja formular was falsch, die falsche :method ist
mein Lieblingsfehler. Und ich weiß es nie auswendig...

ciao, tom


Am 09.10.2008 um 10:16 schrieb Werner L.:

> Das läuft doch alles durchs gleiche Schema das kann doch nicht
> anders behandelt werden.



--
Thomas R. "TomK32" Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32
Werner L. (Guest)
on 2008-10-09 12:42
(Received via mailing list)
Am 09.10.2008 um 10:21 schrieb Michael K.:

Danke für die Tips

Fehler war wohl eine Validierung, die mir völlig o.k. scheint, mal
schaun..erst mal auskommentiert.

sorry wenn ich manchmal so aufgeregt agiere..solche "Wunder" - kann
ich nicht so gut mit umgehen.
Ich bin noch so einem Kandidaten hinterher:
In einer show action werden von ein paar hundert Kunden bei dreien ein
paar Daten doppelt angezeigt. Gleiches template..

Gruß + Danke
Thomas R. Koll (Guest)
on 2008-10-09 13:07
(Received via mailing list)
Am 09.10.2008 um 10:41 schrieb Werner L.:
>
> sorry wenn ich manchmal so aufgeregt agiere..solche "Wunder" - kann
> ich nicht so gut mit umgehen.

Ist pure Erfahrung, wird schon noch.


> Ich bin noch so einem Kandidaten hinterher:
> In einer show action werden von ein paar hundert Kunden bei dreien
> ein paar Daten doppelt angezeigt. Gleiches template..


Ganz sicher? Also nur die Daten, die ids sind gleich und nicht etwa
unterschiedlich?

ciao, tom

--
Thomas R. "TomK32" Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32
Werner L. (Guest)
on 2008-10-09 13:26
(Received via mailing list)
Am 09.10.2008 um 11:07 schrieb Thomas R. Koll:
>> show action werden von ein paar hundert Kunden bei dreien ein paar
>> Daten doppelt angezeigt. Gleiches template..
>
>
> Ganz sicher? Also nur die Daten, die ids sind gleich und nicht etwa
> unterschiedlich?
>

hallo Tom

Die Datensätze sind fast identisch, bis auf die Büroanschrift. Wird
auch korrekt angezeigt. Nur bei einer Darstellung werden alle
sonstigen Angebotsdaten doppelt (komplett 2 mal untereinander )
angezeigt.
Diese Kundin hat zwei Einträge.
  2 Weiter Kunden verhalten sich ebenso, alle anderen sind o.k.

hier die logdaten:


Parameters: {"permalink"=>"Dreyer", "action"=>"index",
"controller"=>"premium"}

   [4;35;1mClient Columns (0.021575)[0m   [0mSHOW FIELDS FROM
`clients`[0m
   [4;36;1mClient Load (0.025829)[0m   [0;1mSELECT * FROM `clients`
WHERE (`clients`.`permalink` = 'Dreyer') LIMIT 1[0m
   [4;35;1mPhoto Columns (0.002036)[0m   [0mSHOW FIELDS FROM `photos`[0m
   [4;36;1mPhoto Load (0.028704)[0m   [0;1mSELECT * FROM `photos`
WHERE (`photos`.`id` = '103') LIMIT 1[0m
   [4;35;1mPhoto Load (0.000613)[0m   [0mSELECT * FROM `photos` WHERE
(`photos`.`id` = '106') LIMIT 1[0m

Rendering template within layouts/premium
Rendering premium/index

Completed in 0.39447 (2 reqs/sec) | Rendering: 0.08532 (21%) | DB:
0.11200 (28%) | 200 OK [http://localhost/premium/Dreyer]


   Parameters: {"permalink"=>"G-Dreyer", "action"=>"index",
"controller"=>"premium"}

   [4;35;1mClient Columns (0.011163)[0m   [0mSHOW FIELDS FROM
`clients`[0m
   [4;36;1mClient Load (0.036158)[0m   [0;1mSELECT * FROM `clients`
WHERE (`clients`.`permalink` = 'G-Dreyer') LIMIT 1[0m
   [4;35;1mPhoto Columns (0.002054)[0m   [0mSHOW FIELDS FROM `photos`[0m
   [4;36;1mPhoto Load (0.000710)[0m   [0;1mSELECT * FROM `photos`
WHERE (`photos`.`id` = '103') LIMIT 1[0m
   [4;35;1mPhoto Load (0.000585)[0m   [0mSELECT * FROM `photos` WHERE
(`photos`.`id` = '106') LIMIT 1[0m

Rendering template within layouts/premium
Rendering premium/index
Completed in 0.11268 (8 reqs/sec) | Rendering: 0.00349 (3%) | DB:
0.05817 (51%) | 200 OK [http://localhost/premium/G-Dreyer]
Thomas R. Koll (Guest)
on 2008-10-09 13:37
(Received via mailing list)
Am 09.10.2008 um 11:25 schrieb Werner L.:
>
> Die Datensätze sind fast identisch, bis auf die Büroanschrift. Wird
> auch korrekt angezeigt. Nur bei einer Darstellung werden alle
> sonstigen Angebotsdaten doppelt (komplett 2 mal untereinander )
> angezeigt.
> Diese Kundin hat zwei Einträge.

Na dann geht's nur darum rauszufinden wie und wann diese doppelten
Einträge entstanden sind.

Ich schau bei sowas nach ob die Einträge schon in der legacy db
doppelt waren.
Wenn nicht, kann ein Blick ins log hilfreich sein, bei einem POST
werdn ja
auch im production.log alle Daten angezeigt.
Falls das immer noch nichts gebracht hat dann hat man wohl irgendwo
Bockmist
gebaut, aber da muss man schon üble hacks machen...
wie alt ist denn das updated_at und created_at der Duplikate?

ciao, tom

--
Thomas R. "TomK32" Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32
bevier (Guest)
on 2008-10-09 13:37
(Received via mailing list)
hi,

> PLötzlich geht das Editieren nicht mehr. Sagt zwar :gespeichert, aber
> ist nichts geändert.
> Wenn ich allerdings einen neuen Datensatz anlege klappt alles..nur mit
> den bisherigen geht es nicht mehr.
> Das läuft doch alles durchs gleiche Schema das kann doch nicht anders
> behandelt werden.

weiß nicht, ob das etwas damit zu tun hat, doch ein vergleichbar
"chaotisches" Verhalten von Daten hatte ich einmal, als ich via
phpmyAdmin (ohne Commit) Daten änderte

;-)

bevier


--
IKI: Infinity Kills Information - how the knowledge of what you're doing
betters the result
http://bussole.de/
Level of Math limits Level of Technology
http://infomath.bussole.de/
4fF method to evaluate databases: compare - count
http://dtp-isw.de/
ML method to grip problems: think - write - relate - count - program
http://dtp-isw.de/

Information: wiederholbare und zusammenhängende Wertveränderung von
Eigenschaften - als mathematische Gruppe erklärt sie einerseits die hohe
Nützlichkeit mengenmathematischer Techniken in der Naturwissenschaft,
andererseits die Notwendigkeiten des Lernens in offenen Umgebungen sowie
Strategie und Aufbau von Informationsverarbeitungen
Werner L. (Guest)
on 2008-10-13 14:25
(Received via mailing list)
Am 09.10.2008 um 11:37 schrieb bevier:

Danke für eure Anregungen..

Wie so oft hatte das "Wunder"  ganz menschliche Hintergründe. Der
Kunde hatte den doppelten Eintrag einfach nochmals in ein Textfeld
kopiert..
Auf die simpelsten Lösungen kommt man zuletzt. zzz
This topic is locked and can not be replied to.