Forum: Ruby zena CMS first public release !

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Gaspard B. (Guest)
on 2008-10-06 12:10
(Received via mailing list)
After 3 years of work in my cave, I am happy to go out in the sunlight
to announce the first public beta release of zena !

In a few words:

Zena is a CMS based on ruby on rails with a very advanced xhtml based
templating language called zafu. Sites have been running in production
mode for nearly 2 years now, so it's quite stable (more then 1340 unit
tests).

One of the most important architecture aspects of this CMS is that it
is based on Single Table Inheritance with the ability to create custom
classes from the web frontend.

More information on this release in this post from the blog:
http://zenadmin.org/473

Videos: http://zenadmin.org/426

I hope you enjoy...

Gaspard
Ryan D. (Guest)
on 2008-10-06 12:33
(Received via mailing list)
On Oct 6, 2008, at 01:08 , Gaspard B. wrote:

> Videos: http://zenadmin.org/426

first video is brokey.
Gaspard B. (Guest)
on 2008-10-06 12:49
(Received via mailing list)
What is wrong with the first video ?

Have you tried watching it on vimeo: http://vimeo.com/1632587 ?
(Guest)
on 2008-10-06 15:10
(Received via mailing list)
looks impressive.
I am looking foward to testing the CMS.

regards
svend
Bobnation (Guest)
on 2008-10-06 18:18
(Received via mailing list)
Fun, source code to read!

On Oct 6, 6:09 am, "removed_email_address@domain.invalid" 
<removed_email_address@domain.invalid>
Gaspard B. (Guest)
on 2008-10-06 18:37
(Received via mailing list)
>
> Fun, source code to read!
The code started with rails 0.9.x (end 2005) and some parts reflect
this old history...

Some interesting parts:

lib/query_builder (pseudo sql query builder)
lib/parser, lib/parser/lib/rules/zafu.rb (template parser)

test/helpers/zena_parser/*.yml (yaml tests for templates)
test/helpers/query_builder/*.yml (yaml tests for pseudo sql)

Do not hesitate to ask questions...

Gaspard
Ryan D. (Guest)
on 2008-10-06 20:50
(Received via mailing list)
On Oct 6, 2008, at 01:47 , Gaspard B. wrote:

> What is wrong with the first video ?
>
> Have you tried watching it on vimeo: http://vimeo.com/1632587 ?

huh... it works now. I went to:

   http://zenadmin.org/en/documentation/page427.html

and the vimeo embedded said it wasn't available.
(Guest)
on 2008-10-06 22:23
(Received via mailing list)
I am having problems both with Git and SVN on Vista.
Both are install correct, the problem seems to come from the
repository.

This is the svn output:
A    trunk\db\init
A    trunk\db\init\base
A    trunk\db\init\base\help.fr.zml
A    trunk\db\init\base\skins
A    trunk\db\init\base\skins\default
svn: Can't check path 'trunk\db\init\base\skins\default\Node-
*popupLayout.zafu':
 The filename, directory name, or volume label syntax is incorrect.


regards
svend
Gaspard B. (Guest)
on 2008-10-06 22:45
(Received via mailing list)
Damn !

I did not suspect that having stars "*" in the filenames would cause
such troubles. I cannot simply rename these files since the
name is used as the template definition:

[class]-[mode]-[format].zafu

An modes with "*" exist inside zena and are used to render special
pages (search result, admin layout, index page). The star is there so
that
these modes cannot be used to display arbitrary pages (ex. /
page43_*index.html will not work).

You could try to use the archive until I find a better prefix that
does not cause these problems.

The compressed version is at: http://zenadmin.org/zena.tgz

Beware though that zena has never been used on a windows box before
and you might find lots of surprises like this one. To avoid loosing
time with installation issues, I would recommend installing a simple
debian box with vmware...
(Guest)
on 2008-10-06 22:55
(Received via mailing list)
I use, windows, osx, linux for development, just currently at my "¤"#
¤"%¤ Vista laptop...
But still it's unsmart to have that type of filenames, they are bound
to be trubble...

But I am looking foward to play with it, more, when I get the time..

regards
svend
Gaspard B. (Guest)
on 2008-10-06 23:22
(Received via mailing list)
You are right, it's not smart.

What about the "+" sign ?

PS: this is ticket #223
(http://zena.lighthouseapp.com/projects/2549-zena/tickets/223
)

Gaspard
(Guest)
on 2008-10-07 00:57
(Received via mailing list)
+ is proberly better, unless you get into trubble, with ruby since +
is an operator....


regards
svend
Gaspard B. (Guest)
on 2008-10-07 11:37
(Received via mailing list)
I fixed #223 by replacing the star with a plus sign. The change has
been pushed to subversion and github.

Gaspard
This topic is locked and can not be replied to.