Forum: Ruby on Rails BackgrounDRB Configuration

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Adam (Guest)
on 2008-10-06 03:01
(Received via mailing list)
Hi all,

I use backgrounDRB with a couple of Rails apps to handle long running
tasks. I'm having a problem with the log messages it produces. When I
start my backgrounDRB server it checks the job queue every 10 seconds
or so, and adds 3 lines to my development/production.log file to
record the SQL query. These log messages are very frustrating, as they
tend to swamp all the useful log information and make my log files
very large, very fast. Is there a way to disable them? Ideally I'd
like to stop the backgrounDRB server from producing any log messages,
unless I explicitly ask it to, or at least redirect them all to a
different file. I'd be happy enough with no log messages at all, as I
don't use it for anything too important. Is there a way to do this?
I've tried playing around with the :log: option in the
backgroundrb.yml config file, but I can't get it to turn logging off,
and there doesn't seem to be a reference for config options anywhere.

Many thanks,
Adam
Bill W. (Guest)
on 2008-10-06 04:45
(Received via mailing list)
Hi Adam,

Adam wrote:
>
> I use backgrounDRB with a couple of Rails apps to
> andle long running tasks. I'm having a problem with
> the log messages it produces.

You might want to ask on the BackgrounDrb list.

Their list is here
:http://rubyforge.org/mailman/listinfo/backgroundrb-devel

HTH,
Bill
Kieran P (Guest)
on 2008-10-06 04:45
(Received via mailing list)
Hello Adam,

See
http://github.com/gnufied/backgroundrb/commit/9785...

The latest backgroundrb codebase contains the ability to turn then
constant
queries off by setting

:persistent_disabled: true

in the backgroundrb.yml config file. Or if you use persistent queues but
don't need them executed that often, change:

:persistent_delay: 10

in the backgroundrb.yml config file to increase the time between each
query.

Unfortunately, there isn't currently a setting to disable persistent
queuing
or increase the delay for one worker and not another (all or nothing).
But
for those that just use the .new_worker syntax, this will work just
fine.

See the "Installing from Git" section at
http://backgroundrb.rubyforge.org/for how to obtain the latest
version.

Regards
Kieran
Adam (Guest)
on 2008-10-06 12:38
(Received via mailing list)
Thanks Kieran, that's exactly what I was looking for

Adam
This topic is locked and can not be replied to.