Forum: Typo Preventing RSS/Atom Fragment Caching for FeedBurner Integrat

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Rich A. (Guest)
on 2007-07-30 01:03
(Received via mailing list)
I recently tried Ben Curren's approach to redirecting
feed requests to FeedBurner:

http://www.jotthought.com/articles/2006/08/31/migr...

His approach works great until Feedburner accesses my
feed. Feedburner's request is handled by Typo, placing
the feed into the fragment cache (apparently).

I say apparently, because every feed accessed after
FeedBurner's request results in Typo handling the
request. When I check my log, I see something like
this:

Processing XmlController#feed (for XXX.XXX.XXX.XXX at
2007-07-29 15:49:56) [GET]
  Parameters: {"format"=>"rss20", "action"=>"feed",
"type"=>"feed", "controller"=>"xml"}
Filter chain halted as
[#<Proc:0xb776fc98@/usr/lib/ruby/gems/1.8/gems/actionpack-1.13.2/lib/action_controller/filters.rb:597>]
did not yield.
Completed in 0.00134 (748 reqs/sec) | Rendering:
0.00010 (7%) | DB: 0.00000 (0%) | 304 Not Modified
[http://depth-first.com/xml/rss20/feed.xml]

But when I clear the fragment cache, RSS/Atom requests
are re-directed to FeedBurner - until the next time
FeedBurner asks for my feed.

So... how can I disable caching of specific types of
content in Typo? What would be an alternative approach
to the one I'm trying?

thanks,
Rich
This topic is locked and can not be replied to.