Forum: Rails-ES Error con gettext

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Fernandez S. (Guest)
on 2007-07-19 18:17
Hola,

iba a cacharrear un poco con gettext pero no he consigo pasar de la
instalación :-(

lo intento instalar con  gem install gettext y me arroja el siguiente
error

Building native extensions.  This could take a while...
ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
ERROR: Failed to build gem native extension.

ruby extconf.rb install gettext
checking for setlocale()... no
checking for nl_langinfo()... no
creating Makefile

make
sh: line 1: make: command not found

me puede alguien aconsejar como instalarlo?

Muchas gracias.
Un saludo.
Rafael G. (Guest)
on 2007-07-19 18:46
(Received via mailing list)
Da la impresión de que no tienes make, si usas alguna distribución
basada en Debian o Debian lo solucionas instalando el paquete
build-essential.

Saludos!


Fernandez S. escribió:
> ERROR: Failed to build gem native extension.
>
> Muchas gracias.
> Un saludo.
>
>

--
Rafael Garcia Ortega

Prueba gratis nuestro nuevo producto GASTOSgem
(http://www.gastosgem.com)
Fernandez S. (Guest)
on 2007-07-19 19:11
> Da la impresión de que no tienes make, si usas alguna distribución
> basada en Debian o Debian lo solucionas instalando el paquete
> build-essential.

toy usando mac osx con un terminal abierto desde locomotive.

Gracias de todas formas, voy a seguir googleando.

Un saludo.
Xavier N. (Guest)
on 2007-07-19 19:25
(Received via mailing list)
El Jul 19, 2007, a las 5:11 PM, Fernandez S.
escribió:
>> Da la impresión de que no tienes make, si usas alguna distribución
>> basada en Debian o Debian lo solucionas instalando el paquete
>> build-essential.
>
> toy usando mac osx con un terminal abierto desde locomotive.
>
> Gracias de todas formas, voy a seguir googleando.

En Mac has de instalar las Development Tools. En el DVD de
instalacion encontraras un package llamado algo parecido a "Xcode",
es suficiente doble-click y seguir los wizards.

-- fxn
Raul M. (Guest)
on 2007-07-19 19:29
(Received via mailing list)
Fernandez S. escribió:
>> Da la impresión de que no tienes make, si usas alguna distribución
>> basada en Debian o Debian lo solucionas instalando el paquete
>> build-essential.
>
> toy usando mac osx con un terminal abierto desde locomotive.

¿Tienes instalado Xcode? Puedes instalarlo desde los discos de
instalación de macosx o descargarlo desde la web de apple:
   http://developer.apple.com/tools/xcode/

Saludos,
   Raul M.
Fernandez S. (Guest)
on 2007-07-19 20:17
Seré cabezón, ya es la segunda vez que me pasa algo parecido.

Muchas gracias a ambos por la colleja.

Un saludo
This topic is locked and can not be replied to.