Forum: Ruby on Rails Tcl/Tk on Mac OS X: LoadError

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Isak N. (Guest)
on 2007-07-07 19:59

I have a problem with Tcl/Tk in OS X, each time i try requiring tk, i
get this:

irb(main):001:0> require 'tk'
LoadError: no such file to load -- tk
        from (irb):1:in `require'
        from (irb):1

I am positive that I have Tcl/Tk installed - i've installed the binary
from ActiveState and I've tried compiling Ruby 1.8.6 myself and I've
tried installing it with MacPorts, but nonetheless it doesn't work.
I've tried ./configure with --enable-mac-tcltk-framework but it seems
that nothing works.

I've also tried tclsh and wish, and i even made a little button in
wish from the terminal, so I am positive that Tcl/Tk is installed, but
Ruby just doesn't know where or something like that.

I've tried googling and searched this forum, and found people with the
same problem, but I never found any solution that worked for me.

What can I do?

Mac OS X 10.4.10
This topic is locked and can not be replied to.