Forum: Radiant CMS Zlib::BufError

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Sharon C. (Guest)
on 2007-07-02 13:29
(Received via mailing list)
I'm having a problem upgrading from 0.6.1 to 0.6.2 on my local (Windows
XP) test machine.  I have tried this on a couple of Windows machines and
each time I get a (Zlib::BufError) buffer error.

On my local machine I have updated Ruby to version 1.8.6 and have
updated Ruby Gems to 0.9.4. I have also tried a clean install of Ruby,
Gems and Radiant on a newly formatted machine, but again get the buffer
error.

Any help would be appreciated.

Thanks

Sharon


C:\>gem update radiant
Updating installed gems...
Attempting remote update of radiant
ERROR:  While executing gem ... (Zlib::BufError)
    buffer error


This e-mail has been scanned for all viruses by MessageLabs.
Sean C. (Guest)
on 2007-07-02 17:03
(Received via mailing list)
There was some discussion of this problem on the Capistrano mailing
list too. Apparently, it's a bug in RubyGems.  Here's the fix, from
Jamis:

-------------------------
P.S. If you are on a Windows machine, and you get Zlib errors trying
to install the Capistrano gem, try this. Find the rubygems/package.rb
file (wherever it happens to be in your Ruby installation), open it
up, and find the zipped_stream method. Then, replace it, wholesale,
with the following:

 def zipped_stream(entry)
   entry.read(10) # skip the gzip header
   zis = Zlib::Inflate.new(-Zlib::MAX_WBITS)
   is = StringIO.new(zis.inflate(entry.read))
 ensure
   zis.finish if zis
 end
------------------------
Cheers,

Sean
This topic is locked and can not be replied to.