Lose the first character

r = r.reverse.chop.reverse # remove the first character

That works, but I bet there’s a nicer method. What do people use? I
thought there would be a pohc method (chop, in reverse).

Thanks.

(pickaxe is up in the other window, I see other ways, but I am curious
if people use one clear word, like chop!)

Check String.[] and Range

‘hhelo’[ 1 … -1 ] # for example…

Am 15.06.2007 um 02:35 schrieb Colin S.:

Colin S. wrote:

   r = r.reverse.chop.reverse  # remove the first character

That works, but I bet there’s a nicer method. What do people use? I
thought there would be a pohc method (chop, in reverse).

if you want to lose the first character try r[/./m]=""
if you want to lose the first byte try r[0,1]=""

Daniel

Daniel DeLorme wrote:

Colin S. wrote:

   r = r.reverse.chop.reverse  # remove the first character

That works, but I bet there’s a nicer method. What do people use? I
thought there would be a pohc method (chop, in reverse).

if you want to lose the first character try r[/./m]=""

Or, non-destructively,

r = r[/.(.*)/m,1]

On Jun 14, 2007, at 9:48 PM, Joel VanderWerf wrote:

Daniel DeLorme wrote:

Colin S. wrote:

   r = r.reverse.chop.reverse  # remove the first character

There are a million ways to do this in Ruby.
Here’s a way that could be readable…
r = ‘some string’
range_end = r.length - 1
r.slice!(1…range_end)

We could def a method that takes a string and does all of this. One
version could return a new string, the other could trim it in place.

def nibble(string)
range_end = string.length - 1
string.slice(1…range_end)
end

Now we can do
r = nibble®

You could also just extend String.

On Jun 14, 8:35 pm, “Colin S.” [email protected] wrote:

    r = r.reverse.chop.reverse  # remove the first character

That works, but I bet there’s a nicer method. What do people use? I
thought there would be a pohc method (chop, in reverse).

Actually, I’ve been wanting a front version #chomp for a long time
too. If I has good names I’d add them to facets.

T.

Trans wrote, On 6/15/2007 9:47 AM:

T.

I thought the pohc! was clever. But maybe left_chop and right_chop (or
lchop rchop) would be better suited names (or rchop for reverse chop)?

Hi,

Am Freitag, 15. Jun 2007, 23:24:29 +0900 schrieb John J.:

range_end = string.length - 1
string.slice(1..range_end)

end

Obey at least some conventions.

class String
def shift
slice! 0, 1 if any?
end
alias lchop shift
end

Bertram

On Jun 15, 2007, at 9:38 AM, Bertram S. wrote:

version could return a new string, the other could trim it in place.
slice! 0, 1 if any?
end
alias lchop shift
end

Bertram
So sweet about it. What conventions do you refer to?
I said you could add to a class, I didn’t do it.
I also was just trying to keep it clear.
String#slice is not well documented in rdoc. ri only gives the
formats and result types.

----------------------------------------------------------- String#slice
str[fixnum] => fixnum or nil
str[fixnum, fixnum] => new_str or nil
str[range] => new_str or nil
str[regexp] => new_str or nil
str[regexp, fixnum] => new_str or nil
str[other_str] => new_str or nil
str.slice(fixnum) => fixnum or nil
str.slice(fixnum, fixnum) => new_str or nil
str.slice(range) => new_str or nil
str.slice(regexp) => new_str or nil

Not the most clear stuff in the world for everyone.
especially this:
str.slice(fixnum, fixnum) => new_str or nil

Uh, what should those fixnums be?
Sure we could sit around and try it in irb, but better descriptions
would be better for rdoc and for everyone.

shift is a pretty poor naming btw. Makes more sense if you are
dealing with an array. Ruby’s strings are not an arrays.
You missed the OP’s goal. You returned the first character.

how about:

Takes a fixnum argument. Returns a new string by removing (or

nibbling) the ‘fixnum’ number of bytes from the string
class String
def nibble(fixnum)
range_end = self.length - 1
slice(fixnum…range_end)
end
end