Forum: Ruby on Rails the infamous /dispatch.fcgi" has failed to remain running fo

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Miquel A. (Guest)
on 2007-06-11 14:17
(Received via mailing list)
Hi,

I had an application up and running with rails and fcgi and I don't
really know how I messed things up.
After hours of trying solutions from the web I have been able to get
the famous
/dispatch.fcgi" has failed to remain running for 30 seconds given 3
attempts, its restart interval has been backed off to 600 seconds.

I've allready tried the most commont solutions... but my configuration
*seems* ok.

My system is a dedicated Fedora box with the kernel 2.4.22-1
my ruby version is:
ruby 1.8.4 (2005-12-24) [i686-linux]


That's what I've allready done:
The shebang of dispatch.fcgi is correct:
its:
#!/usr/local/bin/ruby

and
# which ruby
/usr/local/bin/ruby

my permisions for the dispatchers are:
-rwxrwxrwx   1 vsvvallery root      479 Jun 11 10:34 dispatch.cgi
-rwxrwxrwx   1 vsvvallery root      858 Jun 11 10:34 dispatch.fcgi
-rwxrwxrwx   1 vsvvallery root      480 Jun 11 10:32 dispatch.rb

my log's directory is also writable

in my .httaccess i have:
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

if i execute the dispatch.fcgi from the command line i get:
---
../config/../app/controllers/application.rb:31: warning: found = in
conditional, should be ==
../config/../app/helpers/application_helper.rb:87: warning: string
literal in condition
Status: 500 Internal Server Error
Content-Type: text/html

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<html>
<body>
<!--
  <h1>Application error</h1>
  <p>Change this error message for exceptions thrown outside of an
action (like in Dispatcher setups or broken Ruby code) in public/
500.html</p>
</body>
</html>
-->
----
I've tried to solve the two warnings of the top and they did not
change a thing...

the application is set to production at the moment but I've already
tried to set it to development just to see if I got more output.

Neither of the logs in rails_app/log is growing.

and finally my last lines of my /etc/httpd/logs/error_log are:
--
[Mon Jun 11 11:49:16 2007] [warn] FastCGI: (dynamic) server "/home/
httpd/vhosts/vallery.es/httpdocs/vallery/public/dispatch.fcgi" has
failed to remain running for 30 seconds given 3 attempts, its restart
interval has been backed off to 600 seconds
---

I think that the error may be very simple to solve... but I don't know
what else to try... if someone please can point me in the right
direction I'll be very grateful

Thanks!


I've allready deleted the tmp files, restarted the server, reinstalled
fcgi even tried to go back
This topic is locked and can not be replied to.