Forum: Ruby on Rails attachment_fu help? broken pipe?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
mixplate (Guest)
on 2007-05-30 02:05
Hello,
Weird problem I am experiencing. I can upload files to my s3 account,
but maybe after 4 times, my rails app starts to no longer upload. If i
killall -user dispatch.fcgi, I can upload again for a few times before
it stops. any ideas?

here is my prod.log

EOFError (end of file reached):
   /usr/local/lib/ruby/1.8/net/protocol.rb:133:in `sysread'
   /usr/local/lib/ruby/1.8/net/protocol.rb:133:in `rbuf_fill'
   /usr/local/lib/ruby/1.8/timeout.rb:56:in `timeout'
   /usr/local/lib/ruby/1.8/timeout.rb:76:in `timeout'
   /usr/local/lib/ruby/1.8/net/protocol.rb:132:in `rbuf_fill'
   /usr/local/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
   /usr/local/lib/ruby/1.8/net/protocol.rb:126:in `readline'
   /usr/local/lib/ruby/1.8/net/http.rb:2017:in `read_status_line'
   /usr/local/lib/ruby/1.8/net/http.rb:2006:in `read_new'
....


and after the first crash, i get a new one"

Errno::EPIPE (Broken pipe):
   /usr/local/lib/ruby/1.8/net/protocol.rb:175:in `write'
   /usr/local/lib/ruby/1.8/net/protocol.rb:175:in `write0'
   /usr/local/lib/ruby/1.8/net/protocol.rb:151:in `write'
   /usr/local/lib/ruby/1.8/net/protocol.rb:166:in `writing'
   /usr/local/lib/ruby/1.8/net/protocol.rb:150:in `write'
   /usr/local/lib/ruby/1.8/net/http.rb:1571:in `write_header'
   /usr/local/lib/ruby/1.8/net/http.rb:1536:in `send_request_with_body'
   /usr/local/lib/ruby/1.8/net/http.rb:1522:in `exec'
   /usr/local/lib/ruby/1.8/net/http.rb:1045:in `request'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/connection.rb:41:in `request'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/connection.rb:46:in `call'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/connection.rb:46:in `request'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/base.rb:69:in `request'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/base.rb:84:in `put'
   /vendor/plugins/aws-s3-0.3.0/lib/aws/s3/object.rb:239:in `store'
   /vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu/backends/s3_backend.rb:294:in
`save_to_storage'
   /vendor/plugins/attachment_fu/lib/technoweenie/attachment_fu.rb:369:in
`after_process_attachment'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/callbacks.rb:333:in
`send'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/callbacks.rb:333:in
`callback'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/callbacks.rb:330:in
`each'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/callbacks.rb:330:in
`callback'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/callbacks.rb:243:in
`create_or_update'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/base.rb:1551:in
`save_without_validation!'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/validations.rb:762:in
`save_without_transactions!'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/transactions.rb:133:in
`save!'
   /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connection_adapters/abstract/database_statements.rb:59:in
`transaction'
This topic is locked and can not be replied to.