Forum: Typo how to reset the base_url value?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2007-05-26 02:40
(Received via mailing list)
Hello all,

I recently set up Typo 4.1.1 and made the mistake of accessing it via
one
of the mongrel instances at "localhost:8000", so now Typo seems to think
that this is the default base URL for about half of the links. That is,
after posting a few articles, when I view my blog, some of the links are
to "localhost:8000" and some of them are for "www.bluemarsh.com"
(permalink and tags links are "localhost:8000", but archives and
syndicate
links are okay).

BTW, I found the 'blogs' table and changed the 'base_url' value, then
restarted everything, and cleared the cache several times, but still the
same links are wrong.

So how do I change all of the occurrences of "localhost:8000" to
reference
the proper domain name?

Thanks

n
Frederic de Villamil (Guest)
on 2007-05-26 09:51
(Received via mailing list)
Le 26 mai 07 à 00:20, removed_email_address@domain.invalid a écrit :

> to "localhost:8000" and some of them are for "www.bluemarsh.com"
> reference
> the proper domain name?
>
> Thanks
>
> n

Log in the admin panel, and change it to what you wnat, save your
settings and here you are.

Frédéric

--
Frédéric de Villamil
removed_email_address@domain.invalid                        tel: +33 (0)6 62 19 
1337
http://fredericdevillamil.com         Typo : http://typosphere.org
Nathan F. (Guest)
on 2007-05-26 10:27
(Received via mailing list)
Yes, like I said, I already set the 'base_url' value in the 'blogs'
table. Still, the permalink and tags links are coming from some where
else.

Where else is the URL base value stored?

n
Nathan F. (Guest)
on 2007-05-26 11:20
(Received via mailing list)
Despite using both "typo sweep_cache /path/to/blog" and the rake
"sweep_cache" task, some files were left behind in tmp/cache that
included the old localhost:8000 value. Deleting the files manually fixed
the issue.

This seems like a bug to me.

n
Piers C. (Guest)
on 2007-05-26 16:08
(Received via mailing list)
On 26/05/07, Nathan F. <removed_email_address@domain.invalid> wrote:
> Despite using both "typo sweep_cache /path/to/blog" and the rake
> "sweep_cache" task, some files were left behind in tmp/cache that
> included the old localhost:8000 value. Deleting the files manually fixed
> the issue.
>
> This seems like a bug to me.

It does rather.

Probably a bit late now, but did the sweep cache option from the admin
page work?

I believe that typo sweep_cache /path/to/blog just calls the rake task,
so it sounds like that's not doing the right thing.
Nathan F. (Guest)
on 2007-05-26 19:32
(Received via mailing list)
Yes, I did hit the button on the admin page, too.

I believe to reproduce this:

1. Set up a Typo instance, start (using Mongrel).
2. Access using the "localhost:8000" address and configure for use.
3. Create a blog entry.
4. Realize the problem, change the base_url value.
5. Restart, try clearing the cache, etc. -> links still use old value.
6. Manually remove the files in tmp/cache -> links now use new value.

Thanks

n
Nathan F. (Guest)
on 2007-05-27 00:11
(Received via mailing list)
I may be wrong about the admin page "clear cache" link. I just changed
the base URL in the admin screen, saved the settings, then cleared the
cache, and after reloading the blog view, the links were fine. Maybe
then it is just the rake task that wasn't working?

Sorry if this is not helpful, I just wanted to clear that issue.

Thanks for Typo, it's terrific.

n
This topic is locked and can not be replied to.