Forum: Ruby Coverage!!!

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Koustubh J. (Guest)
on 2007-05-23 15:34
Hi,

Am trying to run my ruby files in rcov task,

here is the code, am using,

begin
  require 'rcov/rcovtask'

   Rcov::RcovTask.new do |t|

    t.test_files = FileList["/**/TestCase/*.rb"]
    t.verbose = true
   end
rescue LoadError
  puts 'Rcov is not available.'
end

There are many .rb files in that TestCase folder but it is showing the
coverage of only one file...

Will you plz help me, how i can get covrage of all .rb files.
Jano S. (Guest)
on 2007-05-23 16:00
(Received via mailing list)
On 5/23/07, Koustubh J. <removed_email_address@domain.invalid> wrote:
>
> Will you plz help me, how i can get covrage of all .rb files.
Please, before reposting the same question, first see the answers you
have already got [1] and comment on them.

J.

[1] http://www.ruby-forum.com/topic/108893#248556
Koustubh J. (Guest)
on 2007-05-23 16:23
Jano S. wrote:
> On 5/23/07, Koustubh J. <removed_email_address@domain.invalid> wrote:
>>
>> Will you plz help me, how i can get covrage of all .rb files.
> Please, before reposting the same question, first see the answers you
> have already got [1] and comment on them.
>
> J.
>
> [1] http://www.ruby-forum.com/topic/108893#248556


I tried the options that u have specified, but it showing coverage for
only one test script that is last one...

Could u plz help me solve it....

thankx...
Jano S. (Guest)
on 2007-05-23 16:36
(Received via mailing list)
On 5/23/07, Koustubh J. <removed_email_address@domain.invalid> wrote:
>
>
> I tried the options that u have specified, but it showing coverage for
> only one test script that is last one...
>
> Could u plz help me solve it....

Ok,

1. do your test scripts have name tc_something.rb or test_something.rb?
if yes, they do not appear in rcov by design. Try plaing with
--include-file or --exclude-only parameters to rcov

2. Check your FileList by adding
   puts t.test_files just after the assignment

This is how my RCovTask looks like (I'm using fixed array of test
files, as I don't want to run each of them. Now I don't remember any
more why I have put --aggregate there.

Rcov::RcovTask.new do |t|
        t.test_files = FileList[*SHORT_TESTS]
        t.output_dir = RCOV_OUTPUT

        t.rcov_opts = [
                "--sort coverage",
                "--sort-reverse",
                "--include-file /\btc_[^.]*\.rb/",
                "--aggregate #{RCOV_DATABASE}"
        ]
end

J.
This topic is locked and can not be replied to.