Forum: GNU Radio Audio Sink Help

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Michael D. (Guest)
on 2007-05-18 07:30
(Received via mailing list)
I've continued to hack away at the wx GUI stuff, primarily for a demo
tomorrow and this coming Monday.  But in the process I've been trying
to figure out what's going on with the Linux-based "aU"s that folks
have brought up in the recent past.  I haven't figured out what's
going on, is the bottom line.  I'm using the latest SVN trunk, and
both the original usrp_wfm_rec.py code as well as my "mod" GUI have
this issue on my Ubuntu Edgy install (on both a VM as well as a real
computer).  Changing the sink's "block" parameter does nothing.  Note
that this does not happen on my OSX box .. the audio sounds crisp and
there is no unexpected text output.  Any thoughts on what I might try
for the demo tomorrow would be appreciated.  I'll check email again
tomorrow around 9:30 AM.  Demo is at ~1 PM.  Lots of work to do
before then.  TIA! - MLD
Justin S. (Guest)
on 2007-05-19 01:35
(Received via mailing list)
Michael D. wrote:
> I've continued to hack away at the wx GUI stuff, primarily for a demo
> tomorrow and this coming Monday.  But in the process I've been trying
> to figure out what's going on with the Linux-based "aU"s that folks
> have brought up in the recent past.
Try setting the audio.sink output option to "plughw:0,0" as in
audio.sink(audio_rate, 'plughw:0,0', False).

Justin
Michael D. (Guest)
on 2007-05-19 05:33
(Received via mailing list)
Justin - Thanks for the tip.  I did figure out how to correct the
issue on my native Ubuntu install: change the sound preferences to
all be for "ALSA" ... no idea why this works, but it did.  The VM
install still doesn't work (even with your tip), but that's probably
a VMware issue. - MLD
This topic is locked and can not be replied to.