Forum: Rails-ES Wysiwyg editor

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Miguel Angel Calleja Lázaro (Guest)
on 2007-05-17 20:14
(Received via mailing list)
Conoceis algún editor wysiwyg que esté bien? permita párrafos, listas,
formatos

He estado probando el Editor de dojo, lo poco que lo he probado no he
visto que tenga para párrafos, si me podeis aconsejar alguno que esté
bien gracias.
Jean Carlo S. (Guest)
on 2007-05-22 06:01
(Received via mailing list)
Aqui te explican como instalar el tinyMCE como un plugin de rails

Saludos,

Jean Carlo Schechnner
Emili P. (Guest)
on 2007-05-22 18:06
Aquí tienes como integrar FCK Editor.

http://www.eparreno.com/ruby-on-rails/integrar-fck...

Miguel Angel Calleja Lázaro wrote:
> Conoceis alg�n editor wysiwyg que est� bien? permita p�rrafos, listas,
> formatos
>
> He estado probando el Editor de dojo, lo poco que lo he probado no he
> visto que tenga para p�rrafos, si me podeis aconsejar alguno que est�
bien gracias.
Miguel Angel Calleja Lázaro (Guest)
on 2007-05-23 19:06
(Received via mailing list)
Jean Carlo S.
escribió:
>     listas,
>
>------------------------------------------------------------------------
>
>_______________________________________________
>Ror-es mailing list
>removed_email_address@domain.invalid
>http://lists.simplelogica.net/mailman/listinfo/ror-es
>
>
No puedo instalarlo:
ruby script/plugin install -x
https://secure.near-time.com/svn/plugins/trunk/tiny_mce
Me dice que mi proyecto no está  bajo subversion, y no lo está, cómo
puedo descargármelo entonces? Gracias
Sergio Gil Pérez de la Manga (Guest)
on 2007-05-23 19:26
(Received via mailing list)
On 5/23/07, Miguel Angel Calleja Lázaro <removed_email_address@domain.invalid> 
wrote:
> No puedo instalarlo:
> ruby script/plugin install -x
> https://secure.near-time.com/svn/plugins/trunk/tiny_mce
> Me dice que mi proyecto no está  bajo subversion, y no lo está, cómo
> puedo descargármelo entonces? Gracias

Quita el -x. Y después empieza a pensar en poner tu proyecto bajo
subversion =;-)

--
Sergio Gil Pérez de la Manga
e-mail > removed_email_address@domain.invalid
blog > http://www.lacoctelera.com/porras
javier ramirez (Guest)
on 2007-05-23 19:27
(Received via mailing list)
Hola
> No puedo instalarlo: ruby script/plugin install -x
> https://secure.near-time.com/svn/plugins/trunk/tiny_mce
> Me dice que mi proyecto no está  bajo subversion, y no lo está, cómo
> puedo descargármelo entonces?
si miras la ayuda de script/plugin verás que la opción -x que estás
usando se utiliza para que te baje el plugin y te lo ponga como svn
external en tu repositorio

simplemente prueba sin la x

saludos,

javier ramirez
Miguel Angel Calleja Lázaro (Guest)
on 2007-05-23 19:38
(Received via mailing list)
javier ramirez
escribió:
>usando se utiliza para que te baje el plugin y te lo ponga como svn
>removed_email_address@domain.invalid
>http://lists.simplelogica.net/mailman/listinfo/ror-es
>
>
>
Ésto es lo que me dice si lo instalo en el servidor:

ruby script/plugin install
https://secure.near-time.com/svn/plugins/trunk/tiny_mce

./script/../config/boot.rb:28:Warning: require_gem is obsolete.  Use gem
instead.
/usr/lib/ruby/1.8/net/http.rb:588:in `connect': certificate verify
failed (OpenSSL::SSL::SSLError)
        from /usr/lib/ruby/1.8/net/http.rb:588:in `connect'
        from /usr/lib/ruby/1.8/net/http.rb:555:in `do_start'
        from /usr/lib/ruby/1.8/net/http.rb:544:in `start'
        from /usr/lib/ruby/1.8/open-uri.rb:245:in `open_http'
        from /usr/lib/ruby/1.8/open-uri.rb:629:in `buffer_open'
        from /usr/lib/ruby/1.8/open-uri.rb:167:in `open_loop'
        from /usr/lib/ruby/1.8/open-uri.rb:165:in `open_loop'
        from /usr/lib/ruby/1.8/open-uri.rb:135:in `open_uri'
         ... 11 levels...
        from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/plugin.rb:871
        from /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
`require'
        from script/plugin:3

En local me dice que el plugin no existe

En el servidor estoy usando la versión 1.1.6 de rails, es el hosting el
que ofrece esa versión, yo no puedo actualizar nada :(

Y lo de usar subversion, primero tengo que aprender cómo funciona y qué
es lo que hace exactamente, pero si quiero aprender a usarlo, poco a
poco...
javier ramirez (Guest)
on 2007-05-23 20:06
(Received via mailing list)
Hola,
> /usr/lib/ruby/1.8/net/http.rb:588:in `connect': certificate verify
> failed (OpenSSL::SSL::SSLError)
>         from /usr/lib/ruby/1.8/net/http.rb:588:in `connect'
eso no es problema del plugin, tiene que ver con tu servidor
> En local me dice que el plugin no existe
>
eso sí es problema del plugin. Mucha gente no sabe cómo publicarlos
bien, y además el instalador de plugins de rails es muy muy básico (el
convention over configuration es lo que tiene, o lo haces exactamente
como se espera, o no va)

el caso es que este plugin no está preparado por lo que veo para
instalarse con un plugin/install

en su lugar vete al directorio plugins de tu proyecto y hazle un

svn co https://secure.near-time.com/svn/plugins/trunk/tiny_mce

lo suyo sería ejecutar después el fichero install.rb del plugin, pero en
este caso es un fichero vacío así que no es necesario


Si no te funciona lo de "svn" es porque no tienes instalado subversion,
y en ese caso te lo deberías instalar

suerte,

javier ramirez
javier ramirez (Guest)
on 2007-05-23 20:09
(Received via mailing list)
NO ME HAGAS CASO A LO DE ANTES ;)

donde te dije que hagas svn co quería decir realmente que hicieras svn
export

svn export https://secure.near-time.com/svn/plugins/trunk/tiny_mce

cuando aprendas svn ya sabrás la diferencia ;)  básicamente te baja
menos ficheros y si un día metes subversion en tu proyecto funcionará
según esperas. Con co te puede dar conflictos

ciao!
Miguel Angel Calleja Lázaro (Guest)
on 2007-05-23 20:29
(Received via mailing list)
javier ramirez
escribió:
>
>instalarse con un plugin/install
>suerte,
>
Si, he probado a instalarlo
así:svn export https://secure.near-time.com/svn/plugins/trunk/tiny_mce

Luego siguiendo los pasos de [1], installo los javascript:

|rake tiny_mce:scripts:install

que creo me los ha metido en
vendor/plugins/tiny_mce/public/javascripts/tiny_mce

He hecho una prueba y parece ser que me funciona bien.
También he estado probando otros editores, pero me gusta más el tinymce.
Muchas gracias a todos
|


|[1] http://www.johnwulff.com/articles/2006/05/31/tinym...
Jean Carlo S. (Guest)
on 2007-05-27 22:09
(Received via mailing list)
Alguien sabe como instalar un plugin de manejo de imagenes como el que
tiene
en php pero en ROR?
This topic is locked and can not be replied to.