Forum: Ruby gem under cygwin - is it supposed to work?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ronald F. (Guest)
on 2007-05-14 20:17
(Received via mailing list)
I am using two installation of Ruby 1.8.5 - one running natively under
Windows, and one
bundled with Cygwin.

The Cygwin installation does not come with gem, so after I had installed
gem 0.9.3 under
Windows, I installed it within my Cygwin environment.

Contrary to the installation under Windows, which issued an error
message, but left me
with a supposedly working "gem" (I have described this problem in a
separate thread),
the Cygwin installation of gem worked without errors, but the usage of
the package
does not seem to work:


$ gem install net-ssh
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (Gem::GemNotFoundException)
    Could not find net-ssh (> 0) in any repository


So I wonder whether gem is intended to work at all under Cygwin. Anyone
already tried this?

BTW, here is my Cygwin gem environment:

$ gem environment
RubyGems Environment:
  - VERSION: 0.9.3 (0.9.3)
  - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
  - GEM PATH:
     - /usr/lib/ruby/gems/1.8
  - REMOTE SOURCES:
     - http://gems.rubyforge.org
Emmanuel Surleau (Guest)
on 2007-05-14 20:22
(Received via mailing list)
On 5/14/07, Ronald F. <removed_email_address@domain.invalid> wrote:
> message, but left me
>     Could not find net-ssh (> 0) in any repository
>   - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
>
>
Try gem install -r net-ssh to install from a remote repository.
Ronald F. (Guest)
on 2007-05-14 20:29
(Received via mailing list)
>
> Try gem install -r net-ssh to install from a remote repository.

Thank you - this worked indeed!

Of course I now wonder why the installation under pure Windows was able
to
locate the net-ssh package without having me specified the "-r"
option....
(I actually never had used -r before in my gem installations).

Ronald
This topic is locked and can not be replied to.