Forum: Ruby Problem with fxruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mariusz Pietrzyk (Guest)
on 2007-05-13 22:39
(Received via mailing list)
Hi
When I require fox16 i get lots of warnings like

/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SHOW_FILES
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_HIDE_FILES
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_TOGGLE_FILES
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SHOW_HIDDEN
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_HIDE_HIDDEN
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_TOGGLE_HIDDEN
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SET_PATTERN
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SORT_REVERSE
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_SORT_CASE
/usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
initialized constant ID_REFRESH

I have ruby 1.8.5 and fxruby 1.6.11, but i also try 1.6.6. at the net I
found that this problem exists,but I can't find way to resolve it.
Joel VanderWerf (Guest)
on 2007-05-13 22:59
(Received via mailing list)
Mariusz Pietrzyk wrote:
> Hi
> When I require fox16 i get lots of warnings like
>
> /usr/lib/ruby/site_ruby/1.8/i686-linux/fox16.so: warning: already
> initialized constant ID_SHOW_FILES
...
>
> I have ruby 1.8.5 and fxruby 1.6.11, but i also try 1.6.6. at the net I
> found that this problem exists,but I can't find way to resolve it.

Can you update ruby to 1.8.6? IIRC that makes the warnings go away.
Mariusz Pietrzyk (Guest)
on 2007-05-13 23:50
(Received via mailing list)
Joel VanderWerf pisze:
>
> Can you update ruby to 1.8.6? IIRC that makes the warnings go away.
>
I've update ruby to 1.8.6 and it works.
Thanks!
This topic is locked and can not be replied to.