Forum: Ruby on Rails no route found to match "/application/signin"

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ryan Cush (Guest)
on 2007-05-03 05:21
I'm posting this because I ran into a problem and had difficulty
tracking down the answer.  In fact, the answer was in another ruby-forum
post, but the Search feature didn't locate it via the keywords I was
using.  Hopefully my Subject line will help more people find this

I upgraded from Rails 1.1.6 to 1.2.3. When I did something that required
me to sign in, I got:

ActionController::RoutingError (no route found to match
"/application/signin" with {:method=>:get}):

Details posted here:

In summary, it seems that the newer versions of Rails enforce that
ApplicationController is not used to contain actions.  It should just
contain utility methods that you want your other controllers to inherit.
Moving my "signin" method to another controller (and fixing all
references to point to this new controller) fixed it.

- Ryan Cush
  "Borrow it, don't buy it!"
This topic is locked and can not be replied to.