Forum: Ruby ruby 1.8.6 errors

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mehdi (Guest)
on 2007-04-17 01:10
(Received via mailing list)
I am trying to compile ruby 1.8.6 on AIX 5.3 TL 6 and gmake gives the
following error

gmake: *** No rule to make target `flock/usr/WebSphere/AppServer.o',
needed by `libruby-static.a'.  Stop. Itreied using both gcc and vac
both gave the same errors.
Your help is appreciated in advance
Yutaka K. (Guest)
on 2007-04-17 07:35
(Received via mailing list)
Hi,

Isn't it AIX5.3 TL5 SP6?
What parameters did you use for configure?
I was able to compile ruby 1.8.6 without any parameters
when using both gcc and vac.
I would like to see the output of `set` as well to check
what kind of environment values are declared.

2007/4/17, Mehdi <removed_email_address@domain.invalid>:
Nobuyoshi N. (Guest)
on 2007-04-17 18:47
(Received via mailing list)
Hi,

At Tue, 17 Apr 2007 06:10:06 +0900,
Mehdi wrote in [ruby-talk:248171]:
> I am trying to compile ruby 1.8.6 on AIX 5.3 TL 6 and gmake gives the
> following error
>
> gmake: *** No rule to make target `flock/usr/WebSphere/AppServer.o',
> needed by `libruby-static.a'.  Stop. Itreied using both gcc and vac
> both gave the same errors.

Autoconf AC_REPLACE_FUNCS appends $U to object file names.  You
seem to set environment variable U to /usr/WebSphere/AppServer.
Try `make U='.
Mehdi (Guest)
on 2007-04-18 17:46
(Received via mailing list)
Yes its TL 5 SP6. Sorry about the typo.
Mehdi (Guest)
on 2007-04-18 19:00
(Received via mailing list)
I used 'make U=" and it worked while compiling using vac. I tried
using gcc and it failed.
 The following is the output of set as you requested and yes "U" is
set to /usr/WebSphere/Appserver.

PWD=/usr/local/ruby-1.8.6
RANDOM=23360
SECONDS=3050
SHELL=/usr/bin/ksh
TERM=xterm
TERM_DEFAULT=lft
TMOUT=0
TZ=EST5EDT
U=/usr/WebSphere/AppServer
USER=root
W=/usr/WebSphere/AppServer
_=U=
all=anim,asna1,asna2,adb,awas,acmrm,acmls,aboap,abodb,ativ,apropwas,apropdb1,apermdb,apropdb2,acmigls,acmigrm
call=app1sna1,app2sna2,db1db,app1was,app2cmrm,db2cmls,app1boap,db1bodb,app2tiv
prompt=#
Yutaka K. (Guest)
on 2007-04-19 07:51
(Received via mailing list)
Hi

2007/4/19, Mehdi <removed_email_address@domain.invalid>:
> I used 'make U=" and it worked while compiling using vac. I tried
> using gcc and it failed.
Are you still getting the same errors with using gcc?
If you see any other errors, please let me know.

I was able to compile ruby 1.8.6 by just doing these commands:
# ./configure --prefix=$HOME/r186
# make
# make install
#  ~/r186/bin/ruby -v -rsocket -e 'p
IPSocket.getaddress("www.ruby-lang.org")'
ruby 1.8.6 (2007-03-13 patchlevel 0) [powerpc-aix5.3.0.0]
"221.186.184.68"
This topic is locked and can not be replied to.