Forum: Ruby on Rails Installing rspec in Windows

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2007-04-13 01:07
(Received via mailing list)
Hi all,
I'm trying to install rspec and I'm having a problem.

C:\Users\Nathan\Documents\rails\myproject> gem install rspec
Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed rspec-0.8.2
Installing ri documentation for rspec-0.8.2...
Installing RDoc documentation for rspec-0.8.2...
C:\Users\Nathan\Documents\rails\myproject> ruby script/plugin install
svn://rubyforge.org/var/svn/rspec/tags/REL_0_8_2/vendor/rspec_on_rails/vendor/plugins/rspec
C:\Users\Nathan\Documents\rails\myproject> ruby script/generate rspec
Couldn't find 'rspec' generator

I have no idea if I'm doing this properly. I just followed the
instructions
on Luke R.'s site. I tried looking for something on rspec.rubyforge
but
couldn't find anything. Any clues?

-Nathan
unknown (Guest)
on 2007-04-13 02:54
(Received via mailing list)
update: I found the instructions on rspec.rubyforge (
http://rspec.rubyforge.org/documentation/rails/install.html), followed
those
instructions, but I still have the same problem.
-N
Jamal S. (Guest)
on 2007-10-06 00:42
unknown wrote:
> update: I found the instructions on rspec.rubyforge (
> http://rspec.rubyforge.org/documentation/rails/install.html), followed
> those
> instructions, but I still have the same problem.
> -N

me too
Hardbap (Guest)
on 2007-10-06 03:14
(Received via mailing list)
Have you tried the plugins?

http://rspec.rubyforge.org/documentation/rails/install.html


On Oct 5, 4:42 pm, Jamal S. <removed_email_address@domain.invalid>
Hardbap (Guest)
on 2007-10-06 03:30
(Received via mailing list)
Sorry, I see that you found the instructions I linked to already.

Do you still have the RSpec gem installed? Did you try removing the
gem before you installed the plugins?
This topic is locked and can not be replied to.