Forum: Ferret intalling ferret

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
raj (Guest)
on 2007-04-05 06:00
i have this error when i try to install ferret

C:\Documents and Settings\>gem install ferret
Need to update 6 gems from http://gems.rubyforge.org
......
complete
Building native extensions.  This could take a while...
ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

ruby extconf.rb install ferret
creating Makefile

nmake
'nmake' is not recognized as an internal or external command,
operable program or batch file.


Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/ferret-0.11.3
for inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/ferret-0.11.3/ext/gem_make.out
David B. (Guest)
on 2007-04-06 07:13
(Received via mailing list)
On 4/5/07, raj <removed_email_address@domain.invalid> wrote:
> ruby extconf.rb install ferret
> Results logged to
> c:/ruby/lib/ruby/gems/1.8/gems/ferret-0.11.3/ext/gem_make.out

You need to install a win32 version of Ferret unless you have Visual
C++ 6.0 installed.

Latest version of win32 gem coming soon...
raj (Guest)
on 2007-04-06 08:38
David B. wrote:
> On 4/5/07, raj <removed_email_address@domain.invalid> wrote:
>> ruby extconf.rb install ferret
>> Results logged to
>> c:/ruby/lib/ruby/gems/1.8/gems/ferret-0.11.3/ext/gem_make.out
>
> You need to install a win32 version of Ferret unless you have Visual
> C++ 6.0 installed.
>
> Latest version of win32 gem coming soon...

is there any existing win32 gem...
David B. (Guest)
on 2007-04-06 08:53
(Received via mailing list)
On 4/6/07, raj <removed_email_address@domain.invalid> wrote:
>
> is there any existing win32 gem...

Yes but it is version 0.10.9. Wait for the next version (0.11.4). It
will be out VERY soon.
captain (Guest)
on 2007-04-09 08:09
David B. wrote:
> On 4/5/07, raj <removed_email_address@domain.invalid> wrote:
>> ruby extconf.rb install ferret
>> Results logged to
>> c:/ruby/lib/ruby/gems/1.8/gems/ferret-0.11.3/ext/gem_make.out
>
> You need to install a win32 version of Ferret unless you have Visual
> C++ 6.0 installed.
>
> Latest version of win32 gem coming soon...

Great, thank you very much.
This topic is locked and can not be replied to.