Forum: Rails France PB Apache 2 et FASTGCI

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A.TONX (Guest)
on 2007-03-26 17:51
(Received via mailing list)
Bonjour,

dans la suite le mise en place de mon serveur de pré-prod, j'ai mon
appli RoR qui fonctionne avec WEBrick, qui fonctionne également avec
Apache 2 + CGI. J'en suis au stade de tenter de le faire fonctionner
avec Apache2 + FASTCGI:

ayant suivi les indications du livre Ruby on Rails de D.THOMAS et DHH,
j'ai
installé:  => mod_fastcgi
  => le kit fastcgi
  => et ruby-fcgi

j'ai
modifié:  => les droits de public/dispatch.fcgi (0755)
  => le owner:group de l'ensemble des répertoires de l'appli
  => placé dans .htaccess la ligne concernant fastcgi
RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]
=> vérifié la première ligne de public/dispatch.fcgi qui est :
#!/usr/local/bin/ruby
ce qui est conforme à mon environnement
=> mise en place <IfModule mod_fastcgi.c>...</IfModule> dans mon
virtualhost.

après tout cela, lors du lacement de la page d'acceuil de mon appli, je
vois s'afficher le conteu texte du fichier public/dispatch.fcgi.

Je pressens que les instructions ruby contenu dans public/dispatch.fcgi
ne sont pas interprétées, et que j'ai du loupé qqu chose...

si l'un d'entre vous à une piste, merci d'avance.

NB: je suis sur une SuSE9.3 avec Apache 2.0.53 et son rpm mod_fastcgi
Frederic de Villamil (Guest)
on 2007-03-26 18:02
(Received via mailing list)
Le 26 mars 07 à 15:48, A.TONX a écrit :

>  => et ruby-fcgi
>
> NB: je suis sur une SuSE9.3 avec Apache 2.0.53 et son rpm mod_fastcgi
>

Il ne te manquerait pas un petit AddHandler quelque part ? par
exemple dans ton vhost ou dans pubblic/.htaccess ?
Et d'ailleurs, ton .htaccess est-il interprété par Apache ?

AddHandler fastcgi-script .fcgi

Et dans ton vhost, un AllowOverride options fileinfo du plus bel effet ?

Cordialement,
Frédéric
--
Frédéric de Villamil
removed_email_address@domain.invalid                        tel: +33 (0)6 62 19 
1337
http://fredericdevillamil.com         Typo : http://typosphere.org
A.TONX (Guest)
on 2007-03-26 18:41
(Received via mailing list)
dans mon fichier apache2/conf.d/mod_fastcgi.conf j'ai:

<IfModule !mod_fastcgi.c>
         <Directory "/srv/www/fcgi-bin">
                 AllowOverride None
                 Options None
                 Order allow,deny
                 Deny from all
         </Directory>
</IfModule>

<IfModule mod_fastcgi.c>
         <Directory "/srv/www/fcgi-bin">
                 AllowOverride None
                 Options +ExecCGI -Includes
                 SetHandler fastcgi-script
                 Order allow,deny
                 Allow from all
         </Directory>
         AddHandler fastcgi-script fcg fcgi fpl
</IfModule>

dans mon fichier apache2/vhost.d/monserveur.conf j'ai:

<VirtualHost *:80>
  ServerName monserveur.com
  ServerAdmin removed_email_address@domain.invalid
  DocumentRoot /path/monappli/public/
  ErrorLog /path/monappli/log/server.log
   <IfModule mod_fastcgi.c>
     FastCgiIpcDir /tmp/fcgi_ipc
     FastCgiServer /path/monappli/public/dispatch.fcgi -initial -env
RAILS_ENV=production -processes 10
  -idle-timeout 60
  </IfModule>
  <Directory "/path/monappli/public/">
    Options +FollowSymLinks +ExecCGI
    AllowOverride all
    Allow from all
    Order allow,deny
  </Directory>
</VirtualHost>


j'ai essayé avec AllowOverride Options FileInfo à la place de
AllowOverride all, je n'ai pas vu de changement de comportement .

Cordialement
AX
Frederic de Villamil (Guest)
on 2007-03-26 18:54
(Received via mailing list)
Le 26 mars 07 à 16:39, A.TONX a écrit :

 >-- snip >-- >-- >-- >-- >-- >-- >-- >-- >-- >-- >-- >-- >-- >-- >--
 >--

>
>
> j'ai essayé avec AllowOverride Options FileInfo à la place de
> AllowOverride all, je n'ai pas vu de changement de comportement .
>
> Cordialement
> AX

Chez moi, les addhandler, y'a des . devant les noms d'extension

AddHandler fastcgi-script .fcg .fcgi .fpl ça viendrait pas de là ?

Et puis, es tu certain d'avoir activé le module kivabien ?

Genre a2enmod fastcgi ?
--
Frédéric de Villamil
removed_email_address@domain.invalid                        tel: +33 (0)6 62 19 
1337
http://fredericdevillamil.com         Typo : http://typosphere.org
A.TONX (Guest)
on 2007-03-26 19:57
(Received via mailing list)
Frederic de Villamil wrote:
>>                 Order allow,deny
>> AX
> removed_email_address@domain.invalid
>
Oups!!

effectivement l'oubli était grossier, le module n'était pas chargé...

merci pour ta patience.

mon appli fonctionne, par contre j'ai une des fonctions qui plantent.
C'est le lancement de la génération d'un pdf via jasperrport qui a
besoin de charger des librairies java qui se trouvent sous la racine de
l'appli RoR 'monappli/jasper/lib'. En mode FCGI, je récupère une erreur
dans production.log:

Errno::ENOENT (No such file or directory - jasper/lib):
....


pourtant le propriétaire, le groupe et les droits me semblent correcte.

De plus cela fonctionnait en mode WEBrick ou CGI avec ce serveur.

Cordialement

AX
This topic is locked and can not be replied to.