Forum: Ruby Help with Camellia

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Guillaume Nargeot (Guest)
on 2007-03-22 03:51
(Received via mailing list)

I've tried to install the computer vision library Camellia for ruby,
the normal way, on linux, with the root account, but while I try to run
test files located into the /test/ directory, I always get the following

guillaume:/home/guillaume/Desktop/CamelliaLib-2.5.10 # ruby
test/test_hough.rb:2:in `require': no such file to load -- lib/camellia
        from test/test_hough.rb:2

I then tried to manually copy the library files into
And then I got the following error while running again the test scripts

/usr/lib/ruby/1.8/lib/ /usr/lib/ruby/1.8/lib/
undefined symbol: __gxx_personality_v0 -
        from ./test/test_labeling.rb:2
        from ts_camellia.rb:2:in `require'
        from ts_camellia.rb:2

Actually, the executable test file (cam_demo) seems to be perfectly
(anyway, I didn't even try to write my own C file and compile it)... but
what I want is to use the ruby interface.

So, is there anynone who has an idea on how to get it working properly ?

Thanks in advance !
This topic is locked and can not be replied to.