Forum: GNU Radio failure to build some components and running usrp examples

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
bellzii (Guest)
on 2007-03-20 00:23
(Received via mailing list)
The following components were skipped either because you asked not
to build them or they didn't pass configuration checks:

gr-audio-jack
gr-audio-osx
gr-audio-portaudio
gr-audio-windows
gr-comedi
gr-video-sdl
ezdop
gr-ezdop

These components will not be built.

(all other critical components were built)


I tried running the usrp_wfm_rcv.py  but i got

Using RX d'board A: Flex 2400 Rx MIMO B
>>> gr_fir_ccf: using SSE
>>> gr_fir_fff: using SSE
audio_alsa_sink[hw:0,0]: Device or resource busy
Traceback (most recent call last):
  File "./usrp_wfm_rcv.py", line 269, in ?
    app = stdgui.stdapp (wfm_rx_graph, "USRP WFM RX")
  File
"/usr/local/lib/python2.4/site-packages/gnuradio/wxgui/stdgui.py",
line 36, in __init__
    wx.App.__init__ (self, redirect=False)
  File
"/usr/lib/python2.4/site-packages/wx-2.6-gtk2-unicode/wx/_core.py",
line 7700, in __init__
    self._BootstrapApp()
  File
"/usr/lib/python2.4/site-packages/wx-2.6-gtk2-unicode/wx/_core.py",
line 7352, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File
"/usr/local/lib/python2.4/site-packages/gnuradio/wxgui/stdgui.py",
line 39, in OnInit
    frame = stdframe (self.flow_graph_maker, self.title, self._nstatus)
  File
"/usr/local/lib/python2.4/site-packages/gnuradio/wxgui/stdgui.py",
line 60, in __init__
    self.panel = stdpanel (self, self, flow_graph_maker)
  File
"/usr/local/lib/python2.4/site-packages/gnuradio/wxgui/stdgui.py",
line 81, in __init__
    self.fg = flow_graph_maker (frame, self, vbox, sys.argv)
  File "./usrp_wfm_rcv.py", line 94, in __init__
    False)  # ok_to_block
  File "/usr/local/lib/python2.4/site-packages/gnuradio/audio_alsa.py",
line
236, in sink
    return _audio_alsa.sink(*args)
RuntimeError: audio_alsa_sink

why is alsa not working does it have to with my RXF2400 daughter being
not
in fm range??

thanks in advance
--
View this message in context:
http://www.nabble.com/failure-to-build-some-compon...
Sent from the GnuRadio mailing list archive at Nabble.com.
Dan H. (Guest)
on 2007-03-20 00:33
(Received via mailing list)
bellzii wrote:
> audio_alsa_sink[hw:0,0]: Device or resource busy
>

That error looks like you've got some application locking the sound
card. Music player, esound, something like that?
> why is alsa not working does it have to with my RXF2400 daughter being not
> in fm range??

Shouldn't be, but that does imply you won't rx any radio...

-Dan
This topic is locked and can not be replied to.