Forum: Ruby on Rails no route found to match "/cookbook/recipe/list" with {:metho

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
VolteFace (Guest)
on 2007-03-18 19:53
(Received via mailing list)
Hi,

I ve just spent about three hours trying to figure this out, so any
help would be appreciated.

I ve followed these steps:

1. Downloaded Instant Rails
2. Unzipped it
3. Ran "InstantRails.exe" to configure it. (path is c:\InstantRails)
4. Went to the "Manage Rails Applications" area and chose "cookbook"
app.
5. Clicked on "Start with Mongrel"
6. Mongrel was started and app was loaded on port 3001.
7. I opened a browser and typed "http://localhost:3000/cookbook/recipe/
list"

And I get this message:
"no route found to match "/cookbook/recipe/list" with {:method=>:get}"

Am I doing something wrong here? I appreciate your help very much.
Ravil B. (Guest)
on 2007-03-18 20:31
I would advise you to try to type http://localhost:3000/recipe/list on
step 7, because u already launched project cookbook and there is next
rule for ruby on rails:
http://"server"/"controller"/"method"...
for u: server - localhost, controller - recipe and method - list
VolteFace (Guest)
on 2007-03-18 20:39
(Received via mailing list)
Thanks a bunch, Ravil.

Your suggestion fixed it.






On Mar 18, 2:31 pm, Ravil B. <rails-mailing-l...@andreas-
Bogdan I. (Guest)
on 2007-03-19 01:37
(Received via mailing list)
I'm not familiar with instant rails, but wouldn't you want to use port
3001
if your app was started on that port?
Curt H. (Guest)
on 2007-03-19 04:29
(Received via mailing list)
On 3/18/07, VolteFace <removed_email_address@domain.invalid> wrote:
> 2. Unzipped it
>
> Am I doing something wrong here? I appreciate your help very much.


Browse to http://localhost:3001/cookbook/recipe/ and it should work.

Curt
Xiu J. (Guest)
on 2008-07-28 04:54
Hi,

I have spent almost my whole Sunday to fix the problem:

"no route found to match "/recipe/list" with {:method=>:get}", or
"no route found to match "/recipe" with {:method=>:get}"
depending on what I put into the browser.

I believe "http://localhost:3001/recipe/list should be the correct one.

I have tried everything and checked through my settings against the
tutorial many times. I still could Not solve the problem.

Could you please help where could go wrong?

Many Thanks!
Conrad T. (Guest)
on 2008-07-28 05:38
(Received via mailing list)
Hi, if you're using the default port,  it should be 3000 instead 3001.
 Thus, I would try using the following:
http://localhost:3000/recipe/list <http://localhost:3001/recipe/list>

Good luck,

-Conrad
Xiu J. (Guest)
on 2008-07-28 11:33
Thank you, Conrad!

After I started Mongrel, the application was loaded on port 3001.
Actually, my configuration steps were as the same as the 7 steps
provided in the orginal post of VolteFace at the top.

Any further information and advice on this could be very much
appreciated.

Please help and I really want a working installation to get me really
started with Rails.

Xiu
Ryan B. (Guest)
on 2008-07-28 11:37
(Received via mailing list)
Is the controller called recipes?

Then it should be localhost:3001/recipes
This topic is locked and can not be replied to.