Forum: GNU Radio Segmentation Fault in

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Tarun T. (Guest)
on 2007-03-16 07:40
(Received via mailing list)

I was trying to use rx_voice and tx_voice examples, but I found
errors on different Fedora PCs.

I have one computer (Pentium 4 Xeon 3.40GHz processor speed) with Kernel
2.6.11-1.1369_FC4smp, and another computer (Centrino Core Duo T2300
1.66GHzprocessor speed) with Kernel

When I run I recieve following errors:
a) on FC4 :  Segmentation Fault
b) on FC5 :  terminate called after throwing an instance of
                  what():  msg length is not a multiple of d_itemsize

Then, I tried installing fftw from source code with following options:
1) ./configure --enable-sse --enable-single --enable-shared
2) ./configure --enable-single --enable-shared
3) ./configure --disable-sse --enable-single --enable-shared

but there was no improvement in the program, though all the make check
worked perfect. Although GNU Radio works pretty well with the current
but I am not able to understand the WHY behind this problem.

Between the time, I am also not able to listen anything on receiver
side. I
am using RFX2400 boards with following commands:

For TX:   ./ --freq 2.41G -M 1 -I plughw:0,0 -v -m gmsk
For RX:  ./ --freq 2.41G -O plughw:0,0 -v -m gmsk

I need help on this issue.

Thanks in advance.

Eric B. (Guest)
on 2007-03-17 00:32
(Received via mailing list)
On Fri, Mar 16, 2007 at 12:39:44AM -0500, Tarun T. wrote:
> When I run I recieve following errors:
> I need help on this issue.
> Thanks in advance.
> Regards,
> Tarun

No clue. It works for me.

This topic is locked and can not be replied to.