Forum: GNU Radio Can't get input from sound card.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bahn William L Civ USAFA/DFCS (Guest)
on 2007-03-15 23:14
(Received via mailing list)
Greetings all,

I'm trying to interact with the sound card. The example programs, such
as dial_tone.py and dialtone_v.py, that output audio work fine. But I
don't seem to me able to get any data from the audio card using such
programs as audio_to_file.py or audio_fft.py.

When I run
[]# audio_fft.py -S

I get the following message:

WARNING **: IPP request failed with status 1030

I don't know if this is an issue or not. I searched the archives and it
appears that many folks have seen it without any adverse affects.

However, I don't seem to actually get any data. The scope runs, but it
is flatlined. I know the soundcard and the microphone are good. I've
tried both the mic input and, out of desperation, the line input jack.

Similarly, when I ran the audio_to_file.py program, it generates a file
of the right length, but when I play it back I hear nothing.

Any ideas?

TIA
Bahn William L Civ USAFA/DFCS (Guest)
on 2007-03-17 09:16
(Received via mailing list)
>
> But I don't seem to me able to get any data from the audio card using
such
> programs as audio_to_file.py or audio_fft.py.
>

I still can't get any input from the sound card. I have installed GNU
Radio on a completely different computer. The dial_tone.py program
works. I get a flat line (it bounces around between -8e-5 and +4e-5)
when I run audio_fft.py in the oscilloscope mode.

In the hopes of perhaps, possibly getting some kind of a response, I'll
try to ask very specific questions.

1) Is the signal source for audio_fft.py supposed to default to the
sound card microphone?

2) If not, what is the default?

3) If not, can I tell it to use the sound card microphone?

4) If yes, how?
LRK (Guest)
on 2007-03-17 15:36
(Received via mailing list)
On Sat, Mar 17, 2007 at 01:15:34AM -0600, Bahn William L Civ USAFA/DFCS
wrote:
> sound card microphone?
>
> 2) If not, what is the default?
>
> 3) If not, can I tell it to use the sound card microphone?
>
> 4) If yes, how?


I'm running FreeBSD and the sound cards are controlled by the 'mixer'
command. There is a similar command in Linux. Maybe 'amixer'?

I have to select the input with the 'mixer', either mic or line. I also
have a control named 'rec' which sets the input volume level. The latest
versions of FreeBSD save the mixer settings across re-boots.

I have not found a way to set these from GR and I have some soundcards
which do show a 'rec' control and do not work. Best I can tell the
soundcard world is a 'black art' and there are no standards.


Maybe someone can shed more light on this.


--
LRK
removed_email_address@domain.invalid
Bahn William L Civ USAFA/DFCS (Guest)
on 2007-03-19 21:36
(Received via mailing list)
> Subject: Re: [Discuss-gnuradio] Can't get input from sound card.
> LRK
> removed_email_address@domain.invalid
>
> On Sat, Mar 17, 2007 at 01:15:34AM -0600, Bahn William L Civ
USAFA/DFCS
> wrote:
> >
> > I still can't get any input from the sound card. I have installed
GNU
> > Radio on a completely different computer. The dial_tone.py program
> > works. I get a flat line (it bounces around between -8e-5 and +4e-5)
> > when I run audio_fft.py in the oscilloscope mode.
> >
> > In the hopes of perhaps, possibly getting some kind of a response,
I'll
>
>
> I'm running FreeBSD and the sound cards are controlled by the 'mixer'
> command. There is a similar command in Linux. Maybe 'amixer'?
>
> I have to select the input with the 'mixer', either mic or line. I
also
> have a control named 'rec' which sets the input volume level. The
latest
> versions of FreeBSD save the mixer settings across re-boots.
>
> I have not found a way to set these from GR and I have some soundcards
> which do show a 'rec' control and do not work. Best I can tell the
> soundcard world is a 'black art' and there are no standards.
>
>
> Maybe someone can shed more light on this.

Thanks LRK, that helped at least some. In the GNOME GUI I found a mixer
under "Preferences-Volume Control". By un-muting the microphone I got it
so that the mike is now live (blow into it and you hear it at the
speaker) and selected it as the capture device. But the GNUradio apps
such as audio_fft.py still show no response.

So although I'm half a step closer, I still think I need at least the
basic answers to the above questions, namely:

1) Is the signal source for audio_fft.py supposed to default to the
sound card microphone?
2) If not, what is the default?
3) If not, can I tell it to use the sound card microphone?
4) If yes, how?

Thanks.
unknown (Guest)
on 2007-03-19 22:12
(Received via mailing list)
I just got the audio_fft.py running, and this is how I did it on a
Fedora
Core 6 x86_64 machine, in KDE with a set of earphones/microphone:

1) started kmix, went to the "Input" selection and enabled "capture"
2) verified that audio_fft.py was responding by starting it in
Oscilloscope mode, ie "./audio_fft.py -S" with Autorange selected and
the
timescale set to 1ms/div.  I can "see" myself typing this email as the
microphone picks up the key-clicks.

3) quit audio_fft.py and restarted it without any flags, ie
"./audio_fft.py"

4) right-clicked on the gui window, and selected the highest db/div
setting, ie 20 db/div.  Otherwise, there was no visible activity on the
scale.  An alternative would be to decrement the reference level, again
by
right-clicking and selecting "Decr Ref Level" several times until you
see
graph activity.  I can now see the broadband spectrum as I snack on some
peanuts, which seems to be centered below 2 kHz.  Incidentally, I can't
seem to whistle above 2.5 kHz.

eric
Bahn William L Civ USAFA/DFCS (Guest)
on 2007-03-19 22:51
(Received via mailing list)
> GNU
> > > Radio on a completely different computer. The dial_tone.py program
> > > works. I get a flat line (it bounces around between -8e-5 and
+4e-5)
> > > when I run audio_fft.py in the oscilloscope mode.
> > >
> > I have not found a way to set these from GR and I have some
soundcards
> > which do show a 'rec' control and do not work. Best I can tell the
> > soundcard world is a 'black art' and there are no standards.
> >

I hate magical, mystery solutions - but here is what worked:

This is for FC5 and the GNOME desktop environment:

Select "Preferences-Volume Control". You should have a mixer panel with
two tabs - Playback and Capture. Select the Capture tab. What you see
appears to depend on the sound card you have, but you'll probably panels
for Line-In, CD, and Microphone. None of these are what you want (gee,
go figure that the 'Microphone' control has no control over the
microphone). What you probably will not see is a panel for 'Capture'. To
get that panel, go to "Edit-Preferences" and check the 'Capture' box.
There are three icons at the bottom - one to slave the two channels
together, one to mute the device, and one to toggle "audio capture from
Capture". You want to un-mute the device and select it for Capture. If
you just un-mute it, there appears to be some bleed through, but you
really need to select it for Capture.

So what's magical and mysterious about this? The fact that I had set it
up just this way and it didn't work. Then, when basically making random
changes to the options, it started working. So keep that in mind.
This topic is locked and can not be replied to.