Forum: Ruby Single Table Inheritance Association Issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Mike (Guest)
on 2007-03-12 18:02
Hi there,

I'm using STI in a new application, and something is terribly wrong with
has_many associations.

Right, so I have number of subclasses that inherit from one concrete
base class. Each sub class can possibly have associations via has_many,
or has_one. When I try to access a collection on the sub class(
subclass.items), I get 'undefined method 'items' for <Subclass>'. The
strange thing is, accessing these subclasses in script/console works
fine, and even works the first time I run the app in some cases. Once I
refresh the page I get this error though.

I'm totally at a loss here. Any help would be greatly appreciated!

Thanks in advance.

Mike.
Gavin K. (Guest)
on 2007-03-12 18:21
(Received via mailing list)
On Mar 12, 10:02 am, Mike <removed_email_address@domain.invalid> wrote:
> I'm using STI in a new application, and something is terribly wrong with
> has_many associations.
[snip]
> I'm totally at a loss here. Any help would be greatly appreciated!

You have posted this question to the ruby-talk forum/newsgroup/mailing
list, which is for general discussion of the Ruby language. You will
probably get a better set of responses if you ask this question on the
ruby-on-rails forum/group, which is for rails-specific questions, as
yours is.

http://groups.google.com/group/rubyonrails-talk
This topic is locked and can not be replied to.