Forum: GNU Radio RFX400 Antenna Connection

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Jeremy Chew (Guest)
on 2007-03-05 12:54
(Received via mailing list)
Hi,

I am trying to eliminate channel error by using a cable to connect two
RFX400s together. The strange thing is that nothing useful seems to get
through when the radios are connected by cable. I have tried attenuation
in
the range from 0 to 40dB and with several cables to no avail. Using
antennas
works much better.

Do you know what is wrong? And what should the cable attenuation be?

Thanks,
Jeremy
David S. (Guest)
on 2007-03-05 15:09
(Received via mailing list)
what is the receive PGA set to?  I find it works best at the midpoint
(35 or so).  you may want to simply scale back your transmit power
with a multiplier block:

gr.multiply_const_cc(0.1)

I don't know exactly what the correct amount of attenuation is, but
40dB sounds like enough (you'll have to wait for Matt or Eric on
that).  one way to tell would be to use the usrp_fft.py and send a
tone into the 400 board, then you could see what the power level is
needed to get the signal in above the noise floor (i.e. strong enough
for GNU Radio to see it).

how far away are the boards from each other?

hope this helps.

David
Matt E. (Guest)
on 2007-03-05 19:41
(Received via mailing list)
Jeremy Chew wrote:
> Hi,
>
> I am trying to eliminate channel error by using a cable to connect two
> RFX400s together. The strange thing is that nothing useful seems to
> get through when the radios are connected by cable. I have tried
> attenuation in the range from 0 to 40dB and with several cables to no
> avail. Using antennas works much better.
>
> Do you know what is wrong? And what should the cable attenuation be?

The cable attenuation needs to be at least 40 dB for safety.  It
probably needs to be more for signal integrity.  Have you adjusted the
receive gain downwards to compensate for the high signal levels?

Matt
Jeremy Chew (Guest)
on 2007-03-08 04:54
(Received via mailing list)
Thanks. Here is an update...

So far I have tried all the following together:
- Increasing the cable attenuation value to 50dB
- Cutting the receive gain setting to 0
- Using high-frequency cables

There is no apparent change, so I may have to cut the transmit power.

Jeremy

----- Original Message -----
From: "Matt E." <removed_email_address@domain.invalid>
To: "Jeremy Chew" <removed_email_address@domain.invalid>
Cc: <removed_email_address@domain.invalid>
Sent: Tuesday, March 06, 2007 1:40 AM
Subject: Re: [Discuss-gnuradio] RFX400 Antenna Connection
David S. (Guest)
on 2007-03-08 04:57
(Received via mailing list)
On Mar 7, 2007, at 9:53 PM, Jeremy Chew wrote:

> Thanks. Here is an update...
>
> So far I have tried all the following together: - Increasing the
> cable attenuation value to 50dB - Cutting the receive gain setting
> to 0
> - Using high-frequency cables
>

FWIW, I have had success with the Rx PGA gain set to max (65dB I
believe) with 40dB of attenuation between the boards, and a TX
multiplier of 2000 (I used the GMSK stuff for testing)...I think this
was around 5dB CNR when I looked at it on the OScope.
This topic is locked and can not be replied to.